Powerglide Slipping - Team Camaro Tech
Transmission & Driveline Transmissions and Differentials

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Nov 8th, 05, 08:11 PM Thread Starter
 
Join Date: Nov 2005
Posts: 3
Powerglide Slipping

I have a 1968 Chevy Impala with a 307 and a Powerglide. Recently the transmission started slipping so I changed the oil. When I removed the drain plug thick black oil came out. So at this point I wondered does transmission oil become tick and black after 37 years? or were the previous owners stupid enough to put motor oil in the transmission?

After I changed the oil and the filter the slipping improved but did not go away. So now I'm wondering is the transmission shot? or is the problem something simple like tightening the band?

If the problem is a band adjustment how do I adjust it and what tools do I need?
saeger is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Nov 9th, 05, 01:58 PM Thread Starter
 
Join Date: Nov 2005
Posts: 3
Re: Powerglide Slipping

help
saeger is offline  
post #3 of 4 (permalink) Old Nov 9th, 05, 02:20 PM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,123
Re: Powerglide Slipping

thick black trans fluid is very not normal.
I would take it to a quick lube that has a power flusher. When you drain the pan, there's still about twice that much fluid in the torque converter, gonna take some flushing to get it all out. Then keep your fingers crossed that no real damage was done.

JimM's firstgens.com Camaro Board

Jimragtop.com New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
post #4 of 4 (permalink) Old Nov 12th, 05, 09:16 AM
Senior Tech
 
Join Date: Feb 2003
Location: Waterloo, Iowa
Posts: 593
Re: Powerglide Slipping

Probably beyone a band adjustment. They are not hard to overhaul! Pull it out, and I will gladly help move you through a checkout and rebuild via here, email, or phone!
Oldani Motorsports is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
PowerGlide Trany - Beginning of the end? mattalin Transmission & Driveline 2 Aug 6th, 05 01:33 AM
Slipping Powerglide jvenice Troubleshooting 3 Dec 15th, 01 07:22 AM
Please help me out! Swap from powerglide to TH350? 1968camaro123 Engine 14 Jul 27th, 01 11:44 AM
Powerglide to TH350 Questions... Chris Edwards Engine 4 Sep 7th, 00 04:35 PM
Speedometer gears - Powerglide vs Turbro-hydramatic g5067 Troubleshooting 11 May 15th, 00 03:10 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome