Turn signal issue - Team Camaro Tech
Camaro Tech General Tech Area
For best results use specific forums

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old Feb 16th, 17, 04:59 AM Thread Starter
Carl
 
Join Date: Feb 2017
Location: Double Oak, TX
Posts: 18
Turn signal issue

Old issue here, but this seems unique; Left turn signal light stays solid, does not blink; right is ok, emergency flashers working fine, new bulbs, ground at radiator bracket is good, sockets look perfect. Was working fine a few days ago. Could the issue be in the steering column?
Carl Shelton is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old Feb 16th, 17, 06:19 AM
Moderator
Brian
 
69-Pace's Avatar
 
Join Date: Jun 2010
Location: Connecticut USA
Posts: 11,012
Garage
Re: Turn signal issue

A simple test is to swap the flasher units between signals and flashers. If the problem stops when the flasher unit is in the signal socket it is a bad flasher unit. If the problem stays it could be the turn signal switch, or a few other items but start with the easy diagnostic. Also check the wiring connection on the steering column commonly called the harmonica for a loose connection.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Z11 Pace Car - L48 350cid/300hp - 4 Speed Muncie 12 bolt rear.

Super Moderator Team Camaro
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
to send me a private message
69-Pace is offline  
post #3 of 8 (permalink) Old Feb 16th, 17, 06:45 AM Thread Starter
Carl
 
Join Date: Feb 2017
Location: Double Oak, TX
Posts: 18
Re: Turn signal issue

Thanks...I'll give those tips a try.
Carl Shelton is offline  
 
post #4 of 8 (permalink) Old Feb 16th, 17, 06:49 AM
Tech Team
Nick
 
Join Date: Sep 2016
Location: California
Posts: 89
I had a the same issue on my right turn signal but only when my headlights were on. I had other strange issues also. Everything was resolved by fixing several ground wire issues.
Nicc21 is offline  
post #5 of 8 (permalink) Old Feb 17th, 17, 09:16 AM
Gold Lifetime Member
Larry
 
Join Date: Oct 1999
Location: Alamogordo, NM, USA
Posts: 908
Re: Turn signal issue

I wonder if the bulbs could be in backwards. When you press the brake pedal, is the brake light filament actually the one that's on? Same with the turn signal. If the tail light and/or the parking light filaments are the ones that are burning instead of the turn signal/brake filaments I could see how the amperage possibly might not be enough to get the flasher to start.

Current Project:
66 Chevy C10 Resto-Mod
Next In Line: 69 Z/28 Resto-Mod
69-er is offline  
post #6 of 8 (permalink) Old Feb 17th, 17, 12:23 PM
Moderator
Brian
 
69-Pace's Avatar
 
Join Date: Jun 2010
Location: Connecticut USA
Posts: 11,012
Garage
Re: Turn signal issue

Yes could also be ground issues but I like to start the diagnostic flow with the less complicated easy tests and the most common causes.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Z11 Pace Car - L48 350cid/300hp - 4 Speed Muncie 12 bolt rear.

Super Moderator Team Camaro
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
to send me a private message
69-Pace is offline  
post #7 of 8 (permalink) Old Feb 17th, 17, 02:04 PM
Super Moderator
Jake-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 29,718
Re: Turn signal issue

The only difference between emerg flashers and turn signals is power source.
Each circuit, including brakes, have their own power from fuse panel.
Emerg & turn are the same after turn signal switch - same wiring.
I would check bulbs for correct install and the correct filament lighting, as suggested, and replace turn signal flasher with a 552 flasher.
A 512 relies on power drawn to flash whereas a 552 does not care, can handle up to 6 bulbs.

Give a man a rescued dog for the health of both their souls.
'I wish the Dollar Store would sell gas. '
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions
Everett#2390 is offline  
post #8 of 8 (permalink) Old Feb 17th, 17, 05:35 PM
R/T
Senior Tech
Jack
 
Join Date: Aug 2007
Location: S/E Pa.
Posts: 572
Re: Turn signal issue

Check the wire connector(turn signal light) in the left front fender. Might be loose..

Matthew 22: 37-39

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.
R/T is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome