94 Camaro has broken high beams and one speed wipers? - Team Camaro Tech
Team Camaro Tech join team camaro
  



Registered users (free) do not see these large ads

Fourth Generation 1993-2002


Reply
 
LinkBack Thread Tools
Display Modes
Old Apr 26th, 12, 02:06 AM   #1 (permalink)
 
Join Date: Apr 2012
Location: San Diego
Posts: 1
Exclamation 94 Camaro has broken high beams and one speed wipers?

I bought my 94 Camaro with a malfunction in the turn signal lever. Signals work fine except the wipers having one speed (highest speed) and non operating high beams.

I'm in need of assistance of what could be the issue here. The lever looks in good condition until operating these units. I'm wondering if it's the spring, a misplaced part, or the switch itself.

Please help me figure out what part I need to order. Thank You!
KeylimeSpy94 is offline   Reply With Quote Quick reply to this message
Reply

Tags
1994, high beams, signal lever, signal switch, wipers
Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.

Email Address:
Location
Location
First Name
Rather than just Hot69, gotta real name?

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


» Recent Discussions
What should I expect to...
Today 10:59 AM
Last post by scblucam
Today 02:31 PM
5 Replies, 123 Views
Chips TV series cars
Yesterday 05:46 PM
by Rarerat
Last post by Rarerat
Today 02:11 PM
4 Replies, 184 Views
rolling rear fenders on...
Mar 30th, 17 02:43 PM
by chrisp1
Last post by dhutton
Today 01:39 PM
14 Replies, 497 Views
Another 69 cowl tag
Apr 26th, 17 04:05 PM
Last post by jdv69z
Today 01:36 PM
9 Replies, 380 Views
1969 Firebird Convertible
Jul 31st, 12 01:47 PM
Last post by mrdoob
Today 01:31 PM
691 Replies, 145,867 Views
looking for 67 camaro
Today 12:17 PM
by mr21313
Last post by mr21313
Today 12:17 PM
0 Replies, 80 Views
POR 15 for inside...
Today 06:12 AM
by Winch
Last post by DT
Today 12:14 PM
4 Replies, 135 Views
1967 camaro fuel sender...
Yesterday 11:08 PM
Last post by rogerh
Today 12:04 PM
4 Replies, 134 Views
Drag racing + autocross...
Today 11:18 AM
Last post by 1stgenCR
Today 11:18 AM
0 Replies, 52 Views
Too rough to save? I'm...
Yesterday 08:19 PM
by Mike-T
Last post by Matt 69
Today 10:48 AM
5 Replies, 182 Views
Powered by vBadvanced CMPS v3.2.3

All times are GMT -7. The time now is 02:54 PM.



Camaros.net - 2009 AutoForums.com
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.