94 Camaro has broken high beams and one speed wipers? - Team Camaro Tech
Team Camaro Tech join team camaro
  



Registered users (free) do not see these large ads

Fourth Generation 1993-2002


Reply
 
LinkBack Thread Tools
Display Modes
Old Apr 26th, 12, 02:06 AM   #1 (permalink)
 
Join Date: Apr 2012
Location: San Diego
Posts: 1
Exclamation 94 Camaro has broken high beams and one speed wipers?

I bought my 94 Camaro with a malfunction in the turn signal lever. Signals work fine except the wipers having one speed (highest speed) and non operating high beams.

I'm in need of assistance of what could be the issue here. The lever looks in good condition until operating these units. I'm wondering if it's the spring, a misplaced part, or the switch itself.

Please help me figure out what part I need to order. Thank You!
KeylimeSpy94 is offline   Reply With Quote Quick reply to this message
Reply

Tags
1994, high beams, signal lever, signal switch, wipers
Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.

Email Address:
Location
Location
First Name
Rather than just Hot69, gotta real name?

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


» Recent Discussions
67Z Coming up @ Mecum...
Today 12:24 AM
Last post by Zedder
Today 02:55 PM
6 Replies, 203 Views
Finding A New Set of...
Today 12:50 AM
by XedLos
Last post by camarodriver67
Today 02:33 PM
4 Replies, 147 Views
Man is this sad....
Sep 29th, 16 03:00 PM
by DOUG G
Last post by jcdubs
Today 02:20 PM
12 Replies, 447 Views
My 67
Mar 21st, 16 07:39 PM
by 3d cad
Last post by 3d cad
Today 02:19 PM
40 Replies, 2,982 Views
Hood goes down easily, 67
Yesterday 07:23 PM
by Rls8836
Last post by jcdubs
Today 02:18 PM
4 Replies, 135 Views
trunk seal comparison
Today 02:13 PM
by 3d cad
Last post by 3d cad
Today 02:13 PM
0 Replies, 29 Views
1967 Trim Tag - Real?
Yesterday 10:47 AM
Last post by 3d cad
Today 02:08 PM
13 Replies, 312 Views
LS7 into a 68
Today 08:44 AM
Last post by Sheck44
Today 02:03 PM
5 Replies, 102 Views
New repro cowl hood
Today 05:59 AM
by DT
Last post by Matt 69
Today 01:34 PM
1 Replies, 87 Views
Alternator bracket ideas
Today 08:57 AM
Last post by DOUG G
Today 01:18 PM
1 Replies, 69 Views
Powered by vBadvanced CMPS v3.2.3

All times are GMT -7. The time now is 03:18 PM.



Camaros.net - 2009 AutoForums.com
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.