High idle problem [Archive] - Team Camaro Tech

: High idle problem


skin86z28
Mar 1st, 07, 07:56 PM
I have an 86 z28 and I'm having an idleing problem. When I start the engine it idles at 2500 rpm. Within about 5 minutes it rises to 3000 and seems to just keep climbing from there. Ive been told it could be the choke, a vacume leak or a problem with the carburetor witch is a 2 barrel rochester quadrajet. Any advise would be greatly appreciated!!!

davidpozzi
Mar 1st, 07, 10:43 PM
It can't be a Z/28 if it has a carburetor, the Z/28 in 1986 would have tuned port injection and be a 305.

On the right side of the carb there is a choke unloader valve. Check it for a leak.
To check it, first remove the vacuum hose, then compress the link sticking out of the valve, cover the hose nipple with your finger and release the link.

If the diaphragm is good, the link will not extend itself more than just slightly. If there is a hole in the diaphragm, the link will extend fully, and when you remove your finger, it will not extend more.

If the choke unloader does not work, the choke can stay on and the engine will run rich and at high speed.

Also check your choke.
David

Rodder
Mar 2nd, 07, 12:00 AM
It can't be a Z/28 if it has a carburetor, the Z/28 in 1986 would have tuned port injection and be a 305.


it's 21 years old, it could be anything... well, anything except a "2 barrel rochester quadrajet" :-D.

Unless that was a joke, like my old front-wheel-drive Jeep Wrangler... (I once drove the Jeep, still under warranty, into the dealership service line, the service writer asked me what the problem was, and I told him "it drives like crap in Front Wheel Drive". He got a really confused look on his face and asked me what I meant. I reached down in the passenger floorboard and picked up the rear driveshaft with 2/3 of the fragged slipyoke still attached and handed it to him. He still didn't quite get it, but I thought it was funny. It was a pretty spectacular failure--blew apart the tailshaft housing of the transfer case too, and the driveshaft swung around and tore the muffler almost in half and left a nice gash in the floorpan.)

skin86z28
Mar 2nd, 07, 03:35 AM
no im not kidding it has a "2 barrel rochester quadrajet" if you want i'll even send you a picture!

Everett#2390
Mar 2nd, 07, 04:25 AM
Reads like a vacuum leak. Check are nipples and their hoses to make sure the hoses are in good shape and no splits and have not fallen off from their nipples.

Did it run good before?
Did it high idle gradully or all at once?

dawg
Mar 2nd, 07, 04:35 AM
no such thing as a rochester 2 barrel quadra jet?
quad is 4.

Rodder
Mar 2nd, 07, 07:24 AM
no im not kidding it has a "2 barrel rochester quadrajet" if you want i'll even send you a picture!

please do, I gotta see that.

click
Mar 2nd, 07, 07:43 AM
Pat, please only post your question in the 1 section that is most proper for it. Multiple posts are against TC policy, it makes it hard for folks that respond to find which one they replied too. Engine is probably the best area for this. Thanks for understanding.

DjD
Mar 2nd, 07, 08:33 AM
no im not kidding it has a "2 barrel rochester quadrajet" if you want i'll even send you a picture!

Quad = 4 as in 4 bbl so you may have a 2 bbl but it's not a "quadrajet"

DjD
Mar 2nd, 07, 08:38 AM
it's 21 years old, it could be anything...

Not in CA... Because of smog laws here the '86 wouldn't be registered and legal to drive without the orig configuration under the hood.

DjD
Mar 2nd, 07, 08:45 AM
It can't be a Z/28 if it has a carburetor, the Z/28 in 1986 would have tuned port injection and be a 305.

That's what I thought too but a quick check on a 3rd gen site shows 3 Z28 configurations, 2 with 4bbl carbs. The '86 El Camino I had was a 4bbl 305 and you can have it. It was computer controled and didn't like to be messed with. The TPI is a much better way to go...

http://www.thirdgen.org/1986-chevy-camaro

DjD
Mar 2nd, 07, 08:49 AM
I have an 86 z28 and I'm having an idleing problem. When I start the engine it idles at 2500 rpm. Within about 5 minutes it rises to 3000 and seems to just keep climbing from there. Ive been told it could be the choke, a vacume leak or a problem with the carburetor witch is a 2 barrel rochester quadrajet. Any advise would be greatly appreciated!!!

So what engine is in your car? If it's not factory (2bbl carb???) let us know what it is along with any modifications and what trans. Much easier to help if we know...

kustomwerker
Mar 2nd, 07, 04:07 PM
chances are, the car is throttlebody injected...is there 2 sets of wires going to the top of the "carb"???if so, you probably need a throttle body base gasket...common problem with them...

davidpozzi
Mar 2nd, 07, 09:38 PM
That's what I thought too but a quick check on a 3rd gen site shows 3 Z28 configurations, 2 with 4bbl carbs. The '86 El Camino I had was a 4bbl 305 and you can have it. It was computer controled and didn't like to be messed with. The TPI is a much better way to go...

http://www.thirdgen.org/1986-chevy-camaro

I think in 1988 GM went to throttle body across the board and carbs were no longer offered.
I owned a 1985 Z/28, (305 TPI) and an 89 IROC (350 automatic, dual cats).

I believe the car has a 2 barrel carb now, no need for proof. I'm just saying that combo is not a Z/28 engine.

Check out the choke unloader valve and be sure it's getting vacuum from the engine.
David

350splayedcaps
Mar 6th, 07, 09:30 AM
I had the same problem. I own an 86' Z28 and an 92' RS. The 92' was TBI and had no idle problems. However, the 86' which I bought last summer as my project always seemed to idle high when it started and seemed to climb in a few minutes. The Z28 is a 305 4bbl H.O. I found out it was all computer controlled. So...I went and changed the son of a gun! No more idle probs. : )