Team Camaro Tech - View Profile: zdld17

zdld17 zdld17 is offline

Gold Lifetime Member

  Visitor Messages

Showing Visitor Messages 1 to 5 of 5
  1. GoCamaro27
    Jan 16th, 12 01:49 PM - permalink
    GoCamaro27
    Hi there. I read a post you wrote aback in 2009 about the Edelbrock 3500 Pro Flo EFI system that you have in your tri-5. I also have the same EFI still in the box, and am thinking about installing it on my ZZ430 clone for my 55 Chevy 4-door. How recently did you install it, and have you upgraded to the Pro-Flo 2 system? Edelbrock offers an upgrade for $1,700, and I'm debating whether to sell it and get another system or upgrade it now.

    Have not ever used the XT but I did use the 3500 Multiport on a ZZ3 crate motor in my Tri Five car. It too produced very good results running thru a 700R4. I got 23 mpg on hiway cruises with 3:70 gears.
    Very easy to tune , on the fly via hand held programmer. I did have to change eprom chip to be compatable with my long duration optional GM cam. I had excellant contact with programming engineer with Edlebrock, he gave me his direct office line to assist me with any problems that I had.
  2. Lexlas
    Jan 20th, 11 08:16 AM - permalink
    Lexlas
    Oh yeah ! Most awesome ride indeed.
  3. Apex
    Aug 17th, 09 07:26 PM - permalink
    Apex
    That is one great picture!!
  4. SPARKY69
    Jul 29th, 09 01:06 PM - permalink
    SPARKY69
    Sweet ride!!!!!!!!!!
  5. Z10 Paceman
    Feb 27th, 09 04:17 PM - permalink
    Z10 Paceman
    Don thats a sweet ride.

  About Me

  • About zdld17
    Location
    2 Dog Town in West Texas
    Interests
    Restorations
    Occupation
    Oil Field Trash/retired
    First Name
    Don
    custom3
    http://
    custom4
    2
  • Signature
    Don
    TC # 349
    Zdld17:69 Z/RS,306, NOR141111, 9N554XXX, 12A, X3G, 59/59,723, AFR 195,CCC282/290HR, TKO 600, BU1122B1E
    http://s102.photobucket.com/albums/m...t=115_1577.jpg

  Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: Today 12:49 PM
  • Join Date: Jan 26th, 05
  • Referrals: 0

  Friends

Showing Friends 1 to 3 of 3
  • 77wolf10.85
    • 77wolf10.85 is offline
  • JimM
    • JimM
    • Gold Lifetime Member
    • JimM is offline
  • Z10 Paceman
    • Z10 Paceman is offline

  Mentions

No results to display...

  Quotes

Aug 31st, 16
11:33 AM - zdld17 quoted COPO in post Re: Recomend a clutch...
Sure it makes sense but i...
10:56 AM - COPO quoted zdld17 in post Re: Recomend a clutch...
So the weights are just myt...
08:33 AM - zdld17 quoted COPO in post Re: Recomend a clutch...
Luk makes CF. So the wei...
Aug 28th, 16
07:34 PM - zdld17 quoted ggsz28 in post Re: Not enough fuel flow for 572?
It's a quick fuel 850. The...
11:01 AM - zdld17 quoted budro6968 in post Re: strange fuel color
What detergent did you use. I...
07:10 AM - budro6968 quoted zdld17 in post Re: strange fuel color
Detergent may have caused r...
Aug 27th, 16
06:46 AM - zdld17 quoted JERRYS 69 Z in post Re: Fuel Pump Pushrod Fail --- Damage to engine??
That #2 bearing is bad. What doe...
Aug 26th, 16
02:52 PM - zdld17 quoted Boucher421 in post Re: Fuel Pump Pushrod Fail --- Damage to engine??
I'm in the process of pulling t...
08:19 AM - zdld17 quoted resto_noob in post Re: strange fuel color
Good words, fellas. Thanks for ...
Aug 25th, 16
07:52 PM - zdld17 quoted resto_noob in post Re: strange fuel color
The fuel system was dry when I ...
06:55 PM - zdld17 quoted sleepsinshed in post Re: Aaw back-up switch
What kind of shifter do you have?...
Aug 24th, 16
05:04 PM - zdld17 quoted Boucher421 in post Re: Fuel Pump Pushrod Fail --- Damage to engine??
Engine is in the car. Are your ...
03:39 PM - zdld17 quoted Boucher421 in post Re: Fuel Pump Pushrod Fail --- Damage to engine??
Anything I should know before p...
Aug 23rd, 16
04:15 PM - cericksen quoted zdld17 in post Re: New guy here...
Welcome Chris, sounds like ...
02:01 PM - zdld17 quoted Boucher421 in post Re: Fuel Pump Pushrod Fail --- Damage to engine??
Zdld17- sorry for the basic que...
01:28 PM - NH69Z28RS quoted zdld17 in post Re: Fuel Pump Pushrod Fail --- Damage to engine??
The brass tip rod is meant ...
Aug 22nd, 16
05:08 PM - zdld17 quoted 87zz28 in post Re: Mystery Pistons
And I know nothing about th...
06:19 AM - zdld17 quoted big gear head in post Re: Bent rear
This isn't high carbon steel. It s...
Aug 21st, 16
07:44 AM - zdld17 quoted cv2065 in post Re: Losing a Bearing or Two or Three?...Ugh
Yep, I know exactly what yo...
07:30 AM - cv2065 quoted zdld17 in post Re: Losing a Bearing or Two or Three?...Ugh
If motor is on a test stand...
 
For the best viewing experience please update your browser to Google Chrome