94 Camaro has broken high beams and one speed wipers? - Team Camaro Tech
Team Camaro Tech join team camaro
  



Registered users (free) do not see these large ads

Fourth Generation 1993-2002

Reply
 
Thread Tools Display Modes
  #1  
Old Apr 26th, 12, 03:06 AM
KeylimeSpy94 KeylimeSpy94 is offline

McKenna
 
Join Date: Apr 2012
Location: San Diego
Posts: 1
Exclamation 94 Camaro has broken high beams and one speed wipers?

I bought my 94 Camaro with a malfunction in the turn signal lever. Signals work fine except the wipers having one speed (highest speed) and non operating high beams.

I'm in need of assistance of what could be the issue here. The lever looks in good condition until operating these units. I'm wondering if it's the spring, a misplaced part, or the switch itself.

Please help me figure out what part I need to order. Thank You!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
1994, high beams, signal lever, signal switch, wipers
Team Camaro Tech > Generation Specific Forums > Fourth Generation      Current Topic: 94 Camaro has broken high beams and one speed wipers?
Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.

Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 05:44 AM.



Camaros.net - 2009 AutoForums.com