Blower Not Blowing at All - Team Camaro Tech
Team Camaro Tech join team camaro
 
Camaro Parts at SS396.com     
GROUND UP & SS396.com         
Official Sponsor of Team Camaro
   

Auto Insurance



Registered users (free) do not see these large ads

Electrical & Wiring Troubleshooting electrical.

Reply
 
Thread Tools Display Modes
  #1  
Old Nov 7th, 12, 02:57 PM
327!275hp!Convt! 327!275hp!Convt! is offline
Senior Tech

 
Join Date: Aug 2001
Location: Dallas, Texas
Posts: 798
Default Blower Not Blowing at All

How do I test my a/c relay on top of the fiberglass evaporator box?

I know it is getting electricity when I pull down on the dash switch because the test light comes on.

The test light also goes on when I test the high speed (orange wire) position of the dash switch to the relay.

I can definitely hear the relay ďclickĒ when I try to turn the blower fan on.

I unplugged the purple wire to the relay & hooked it straight up to the positive side of the battery.

The blower motor still doesnít come on. Iím sure my ground wire is good.

Do these blower motors just suddenly go out without any warning?

If I have to buy a new blower motor, is there one that blows stronger than the original?

67 Camaro with a/c

Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old Nov 7th, 12, 04:05 PM
Kevs67RSSS's Avatar
Kevs67RSSS Kevs67RSSS is offline
Gold Lifetime Member

Kevin
 
Join Date: Oct 2012
Location: Crestview FL
Posts: 36
Default Re: Blower Not Blowing at All

Sounds like a it is the blower motor and I don't know of a stronger motor on the market. Check with Classic Industries or Firewheel Classics. Their tech line should be able to answer your question on the motor. Especially Classic Industries. But Firewheel is a great family owned business dedicated to only 1st gen Camaros. I wish I could give you more definite info but that's all I got. Good luck.
Reply With Quote Quick reply to this message
  #3  
Old Nov 7th, 12, 05:12 PM
327!275hp!Convt! 327!275hp!Convt! is offline
Senior Tech

 
Join Date: Aug 2001
Location: Dallas, Texas
Posts: 798
Default Re: Blower Not Blowing at All

Yeah I know Patty & Mary very well; Iím a regular customer at Firewheel. In fact Iím trying to get a job there if they ever hire someone new. JPMorgan Chase Bank sent my job to India.
Reply With Quote Quick reply to this message
  #4  
Old Nov 7th, 12, 05:17 PM
Everett#2390's Avatar
Everett#2390 Everett#2390 is offline
Moderator

<Jake 68's Rule
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 27,365
Default Re: Blower Not Blowing at All

You could take the power lead to the motor and insert an ammeter in line then connect the power ammeter to the battery.
With a locked rotor, frozen motor, max amps will be drawn, otherwise, a smaller current demand wil be indicated if motor is running.
And yes, if the blower was flowing less air over its life from earlier history, it may have just decided to go belly up.
Or the plastic squirrel cage broke and finally jammed the motor.
__________________
Give a man a rescued dog for the health of his soul.
'With enough thrust, pigs can fly.' Other Stuff
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply
Team Camaro Tech > First Generation Camaro Info and Tech - 1967- 1969 "Where it all started" > Electrical & Wiring      Current Topic: Blower Not Blowing at All
Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.

Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:35 AM.



Camaros.net - © 2009 AutoForums.com