Jerky Steering - Team Camaro Tech
Team Camaro Tech join team camaro
 
Camaro Parts at SS396.com     
GROUND UP & SS396.com         
Official Sponsor of Team Camaro
   

Auto Insurance



Registered users (free) do not see these large ads

Brakes, Suspension & Steering Conversion questions, Steering & Handling

Reply
 
Thread Tools Display Modes
  #1  
Old Jan 6th, 13, 09:01 AM
rhcdmd rhcdmd is offline
Team Member

Robin
 
Join Date: Sep 2011
Location: Columbus, MS
Posts: 86
Default Jerky Steering

I have been having jerky difficult steering at very low rpms (mostly degotiating tight spaces and parking) with my power steering in my 69. After reading some forum threads, I decided to see if there was air in the system. The belt looked OK and there was no problem when driving. I lifted the front wheels off the ground. The fluid level in the pump reservoir was at full cold. I cycled the steering wheel through 60 cycles from stop to stop with the cap off the reservoir. There was no fluid overflow and no foaming, but the fluid level was at full hot when I got through. I am not sure what this means or if I should draw off some fluid to full cold since the engine was not run during this procedure. Any advice before I take it off the jack stands and put it back on the ground?

Edit: A couple of hours later the level was still at full hot. I disconnected the coil and turned the engine over several times. The fluid level returned to full cold. Does this mean anything? I still have it up on the jackstands.

Edit: I had my wife turn the wheels through several cycles while I watched the fluid level. The level has a slight rise as the wheel approaches the left and right stops in each cycle.
__________________
1969 SS 396/375
11C Norwood
M21 3.73 12 bolt
http://www.camaros.net/forums/album.php?albumid=956

Last edited by rhcdmd; Jan 6th, 13 at 11:07 AM. Reason: new information
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old Jan 6th, 13, 11:44 AM
allanjs allanjs is offline
Senior Tech

Al
 
Join Date: Jun 2007
Location: Iowa
Posts: 1,372
Default Re: Jerky Steering

Robin, There are a couple things to do and possibly a little more needed info.
Is this an original style powering steering pump? With the car on stands, run
the engine and cycle the wheels from lock to lock a few times. Do you notice
any resistance or jerkiness? Grease the complete steering system, ball joints,
etc. You may have a dry joint or a joint going bad. If you don't notice a
problem with the wheels off the ground, are you running wide front tires
causing extra resistance? How old is the power steering fluid? Unless you very
recently changed it, do so with fresh fluid. Add a small amount of Sea Foam
Trans Tune (or similar) and see if that helps. The problem could be a steering
joint, the pump, steering gear, or tire width.
__________________
Al

my 67' build thread: http://www.camaros.net/forums/showthread.php?t=190185
Reply With Quote
  #3  
Old Jan 6th, 13, 11:58 AM
rhcdmd rhcdmd is offline
Team Member

Robin
 
Join Date: Sep 2011
Location: Columbus, MS
Posts: 86
Default Re: Jerky Steering

To my somewhat limited knowledge, it is an original syle pump. The fluid is about 6 months old. The car has had a ground up restoration which was completed in June 2012, so lube should be OK. I guess the only thing left to do, is start it up and check it and then put it on the ground. No wide front tires. I'll see what happens.
__________________
1969 SS 396/375
11C Norwood
M21 3.73 12 bolt
http://www.camaros.net/forums/album.php?albumid=956
Reply With Quote
  #4  
Old Jan 6th, 13, 12:51 PM
rhcdmd rhcdmd is offline
Team Member

Robin
 
Join Date: Sep 2011
Location: Columbus, MS
Posts: 86
Default Re: Jerky Steering

It seemed to do OK turning the wheel while the engine was running and wheels off the ground. However, when I put it on the ground there was no change. It is still jerky as though the belt were slipping, but I'm pretty sure that the belt is OK. Guess it may be time for a trip to the shop. Any comments?
__________________
1969 SS 396/375
11C Norwood
M21 3.73 12 bolt
http://www.camaros.net/forums/album.php?albumid=956
Reply With Quote
  #5  
Old Jan 6th, 13, 03:03 PM
allanjs allanjs is offline
Senior Tech

Al
 
Join Date: Jun 2007
Location: Iowa
Posts: 1,372
Default Re: Jerky Steering

Robin, Chances are the pump is week from what you are describing. Changing
the fluid and adding an additive might be worth a try. It's easy and fairly
cheep. Try this. With the car on the ground, have an assistant turn the wheel
lock to lock while you observe the power steering hoses (with the engine running).
If the hoses appear to jump or surge, that would indicate a bad pump (not holding
pressure). Even if they do jump, changing the fluid might cure it.
__________________
Al

my 67' build thread: http://www.camaros.net/forums/showthread.php?t=190185
Reply With Quote
  #6  
Old Jan 6th, 13, 04:08 PM
john68 john68 is offline
Gold Lifetime Member

John
 
Join Date: Dec 2008
Location: Louisville, Ky.
Posts: 3,234
Default Re: Jerky Steering

You may still have belt slip. Try a timing light, put a chalk mark or a piece of tape on p/s pully, watch with timing light, if pully jumps/jurks recheck the belt??
Reply With Quote
  #7  
Old Jan 8th, 13, 12:36 AM
davidpozzi davidpozzi is offline
Moderator

David Pozzi
 
Join Date: Nov 1999
Location: Central California, USA
Posts: 9,401
Default Re: Jerky Steering

Put one or two strips of masking tape on the front face of the PS pulley & test it. It's very common for the PS belt to slip. Max load is turning the wheels with the brakes on, the tires have to skid. If the belt ever got oil on it the problem can get worse. Make sure the belt isn't bottoming in the pulley grooves. 67/68's with standard pulleys use thin belts which are barely adequate. High performance Z28 pulleys are way better.
__________________
Check my web page for First Gen Camaro suspension info: http://www.pozziracing.com
67 RS 327 original owner. 1965 Lola T-70
Reply With Quote
  #8  
Old Jan 8th, 13, 06:22 PM
rhcdmd rhcdmd is offline
Team Member

Robin
 
Join Date: Sep 2011
Location: Columbus, MS
Posts: 86
Default Re: Jerky Steering

John,
It was the belt. Works great now. Since I added vintage air and a compressor, the belt doesn't get a lot of "grab" on the pump pulley. The belt doesn't wrap around the pulley very much. Guess I should have know to check the simplest solution first and not always believe my "lyin' eyes."

Robin
__________________
1969 SS 396/375
11C Norwood
M21 3.73 12 bolt
http://www.camaros.net/forums/album.php?albumid=956
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:29 AM.



Camaros.net - 2009 AutoForums.com