91 Z28 issue - Team Camaro Tech
Team Camaro Tech join team camaro
 



Registered users (free) do not see these large ads

Third Generation 1982-1992

Reply
 
Thread Tools Display Modes
  #1  
Old Jan 25th, 14, 08:20 AM
91 Z28 91 Z28 is offline

 
Join Date: Jan 2014
Location: Newfoundland, Canada
Posts: 5
Default 91 Z28 issue

I recently picked up a 91 Z28, 305 tpi, the car starts fine and idles perfectly but when I put it in gear it stalls, I'm thinking it could be the egr valve, what do u guys think?
__________________
91 Z28 305 TPI
Reply With Quote Quick reply to this message
  #2  
Old Jan 25th, 14, 09:39 AM
ZZ430DropTop67RS's Avatar
ZZ430DropTop67RS ZZ430DropTop67RS is offline
Senior Tech

Don
 
Join Date: May 2001
Location: Crockett, Texas
Posts: 3,523
Default Re: 91 Z28 issue

You might try looking at the IAC (idle air control) valve. The pintel can clog. Very common. Clean the tip and the passage in the throttle body with carb spray.

Also the throttle blades themselves.
__________________
Don ~ TC Member #15 ~ http://www.flickr.com/photos/46701464@N06/sets/

Last edited by ZZ430DropTop67RS; Jan 25th, 14 at 09:53 AM.
Reply With Quote Quick reply to this message
  #3  
Old Jan 25th, 14, 10:06 AM
91 Z28 91 Z28 is offline

 
Join Date: Jan 2014
Location: Newfoundland, Canada
Posts: 5
Default Re: 91 Z28 issue

Thanks, I'll give that a try
__________________
91 Z28 305 TPI
Reply With Quote Quick reply to this message
  #4  
Old Jan 25th, 14, 10:20 AM
Obsessive Camaro Disorder Obsessive Camaro Disorder is offline
Tech Team

Jason
 
Join Date: Oct 2011
Location: Iowa
Posts: 48
Default Re: 91 Z28 issue

i had a bad ignition module that acted similar. you can have it checked at a parts store.
Reply With Quote Quick reply to this message
  #5  
Old Mar 6th, 14, 02:45 PM
91 Z28 91 Z28 is offline

 
Join Date: Jan 2014
Location: Newfoundland, Canada
Posts: 5
Default Re: 91 Z28 issue

I had the car running last night and just let it idle to see if it would she a cel, it didn't but after so long idling it just stalled, it started right back up and idled for another while before it stalled again, anyone have any idea what could be wrong?
__________________
91 Z28 305 TPI
Reply With Quote Quick reply to this message
  #6  
Old Mar 6th, 14, 03:10 PM
Everett#2390's Avatar
Everett#2390 Everett#2390 is online now
Moderator

<Jake 68's Rule
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 27,444
Default Re: 91 Z28 issue

Temporally install a fuel pressure gauge on the rail fitting just to see if f/pump is still working.
Could either be the pump overheating with less than a 1/4 tank of fuel or the f/pump relay having burnt contacts internally due to the current drawn overheating the closed contacts.
__________________
Give a man a rescued dog for the health of his soul.
'With enough thrust, pigs can fly.' Other Stuff
Reply With Quote Quick reply to this message
  #7  
Old Mar 6th, 14, 08:31 PM
Obsessive Camaro Disorder Obsessive Camaro Disorder is offline
Tech Team

Jason
 
Join Date: Oct 2011
Location: Iowa
Posts: 48
Default Re: 91 Z28 issue

Quote:
Originally Posted by 91 Z28 View Post
anyone have any idea what could be wrong?
what have you tried so far? Did you take the ignition module to be checked?
Reply With Quote Quick reply to this message
  #8  
Old Mar 11th, 14, 04:56 PM
91 Z28 91 Z28 is offline

 
Join Date: Jan 2014
Location: Newfoundland, Canada
Posts: 5
Default Re: 91 Z28 issue

I have been working a lot lately and haven't had any time to spend at the car, hopefully gonna get at it the weekend.
__________________
91 Z28 305 TPI
Reply With Quote Quick reply to this message
  #9  
Old Apr 7th, 14, 07:34 PM
Obsessive Camaro Disorder Obsessive Camaro Disorder is offline
Tech Team

Jason
 
Join Date: Oct 2011
Location: Iowa
Posts: 48
Default Re: 91 Z28 issue

Get things worked out?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply
Team Camaro Tech > Generation Specific Forums > Third Generation      Current Topic: 91 Z28 issue
Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.

Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 07:22 AM.



Camaros.net - 2009 AutoForums.com