Need help with 1st gen heater box - Team Camaro Tech
Tech 2000 Our previous General Forum
Replies ONLY - no new topics.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Jan 14th, 00, 08:07 AM Thread Starter
 
Join Date: Nov 1999
Location: Virginia
Posts: 7
Question

Trying to remove the heater box from my 69 BB Camaro. Removed the 5 nuts on the firewall side as directed, the heater hoses, etc but the box is only loose on one side. My assembly book shows 2 fasteners around the blower motor. Do these need to be removed??? and how the hell do you reach them???? Any help would be appreciated.

Thanks.
Bob 69 RS/SS is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Jan 14th, 00, 09:20 AM
Senior Tech
 
Join Date: Oct 1999
Location: Cottage Grove, MN
Posts: 217
Post

I may not be much help, But... I just re-built mine, only it's a SB. I pulled the 5 screws on the firewall side as you indicated, I then removed all the cables going to the box itself. Once these were free, I was able to drop the heater box on the inside of the car with little effort. The seal between the box and firewall may be a little sticky and hold the box in place. If I'm not mistaken, to gain access to the blower on the engine side of the fire wall,you actually need to remove the front right fender.

------------------
Shawn Peterson
1969 Z28, 406SB
http://www.geocities.com/corsican69
Shawn is offline  
post #3 of 5 (permalink) Old Jan 14th, 00, 10:46 AM
Senior Tech
 
Join Date: Jan 2000
Location: Houston, TX USA
Posts: 797
Post

Shawn from above is correct, you will need to remove the passenger fender to reach the remaining screws holding the heater box and then to remove the box as well. This is not a fun or easy task to do.. Good luck
Go69 is offline  
 
post #4 of 5 (permalink) Old Jan 14th, 00, 02:27 PM Thread Starter
 
Join Date: Nov 1999
Location: Virginia
Posts: 7
Post

Thanks guys. That sure makes my day. Seems like a sh*tty way to do things, like the blower motor never fails.
Bob 69 RS/SS is offline  
post #5 of 5 (permalink) Old Jan 14th, 00, 02:46 PM
CJ
Senior Tech
Cris
 
Join Date: Dec 1999
Location: Livermore, CA USA
Posts: 292
Cool

I JUST PULLED OFF THE INNER FENDER LINER AND THAT GAVE ME ENOUGH CLEARANCE
CJ is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome