150mph speedo without an Odometer ??? - Team Camaro Tech
Tech 2000 Our previous General Forum
Replies ONLY - no new topics.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 19 (permalink) Old May 28th, 00, 12:43 PM Thread Starter
 
Join Date: May 2000
Location: Napa,Ca,U.S.A.
Posts: 8
Anybody ever seen a 70 Camaro without an Odometer ? Have not been able to find anybody who can even guess as to why I have no Odometer ?
Here is the address of a picture of my speedo
http://members.aol.com/natdevris/images/mvc-036s.jpg

How do I link a picture here?
?

------------------
Nat deVries
70 Camaro 350,4 speed
74 Type LT 350,Auto
Nats70z28 is offline  
Sponsored Links
Advertisement
 
post #2 of 19 (permalink) Old May 28th, 00, 01:27 PM
Gold Lifetime Member
 
stevo camaro's Avatar
 
Join Date: Mar 2000
Location: Dunsmuir, CA
Posts: 1,969
Garage
Hi nat, UHHHH, No, never seen one, never heard of one. It does look factory. What about the rest of the car? Maybe there's some clues as to what the car was or is. 150 MPH speedo is kinda high also. Was it a big block car? What kind of trans? Rearend? It seems strange it would have a speedo like that with no other factory gauges. You might want to look up under the dash to make SURE nobody has installed it themselves. Maybe the guy's on the 2nd generation site have heard of this? I'd like to know what you find out. Good luck.

------------------
Steve
67 SS 396,4-sp
67 RS 327,4-sp
72 RS 350/350
69 4X4 suburban 350,4-sp
73 3/4 ton 454/400
http://www.geocities.com/stevocamaro
stevo camaro is offline  
post #3 of 19 (permalink) Old May 28th, 00, 04:40 PM
DjD
Retired
Dennis
 
DjD's Avatar
 
Join Date: Apr 1999
Location: Fortuna, CA
Posts: 26,435
Garage
What's in the other guage hole behind your tach? There is a blured out spot at the bottom of the spedo, what is it?

------------------
...Dennis
Topless'69
[email protected]
DjD is offline  
 
post #4 of 19 (permalink) Old May 28th, 00, 08:44 PM
 
Join Date: May 2000
Location: CALIFORNIA
Posts: 11
WELL MY FRIEND HAS A 70 CAMARO AS WELL, FIRST OF ALL THE SPEEDO APPEARS TO BE ON THE LEFT WHICH IS NOT FACTORY. THE FACTORY SPEEDO IS ON THE RIGHT SIDE OF THE STEERING WHEEL, THE LEFT WAS EITHER A TACH OR A CLOCK.....THE 150 MPH IS ACTUALLY CORRECT...ONLY THING I CAN THINK OF IS THAT IT WAS REPLACED WITH A LATER MODEL SPEEDO WHERE THE ODOMETER WAS ON THE DASH ON ITS OWN
BAD97Z28CONV is offline  
post #5 of 19 (permalink) Old May 29th, 00, 12:28 PM
Senior Tech
 
Join Date: Apr 2000
Location: pa
Posts: 579
yes 150 is correct. i have an extra 70' 150mph WITH odometer. if you want to replace it with a correct one,let me know. http://members.spree.com/entertainment/ochrisl/

------------------
68 camaro,hugger orange ,white stripes.327 4 speed.
ochrisl is offline  
post #6 of 19 (permalink) Old May 29th, 00, 11:09 PM Thread Starter
 
Join Date: May 2000
Location: Napa,Ca,U.S.A.
Posts: 8
Thanx all for answering !
stevo camaro;Just to let you know where I stand , I'm fairly familiar with Cars of this age Ive owned Far to many to list. I am a Mechanic and I Pride Myself on doing things Correctly ! (MOST OF THE TIME)at Present I own 2 Camaros My 70 that I bought about a year ago and my 74 which ive owned for about 15 years . On with your questions !!! The Car is a 1970 camaro with a 350, 4 speed ,the Car Had Z-28 wheels (I replaced and put z-28s in storage until I can Restore them)The speedo Looks like it was made to be there and doesnt show any signs that it was not the same age as the other parts of the cluster . Ive looked at a couple of other 70's and they appeared the same but with an odometer one of the 70's I saw Had EXSACTLY the same setup 150 speedo idiot lights and a (DjD-> )Fuel Gauge in the other large Hole ! but his also had an odometer ! As far as the blurred spot on the picture ? I have not EDITED this at ALL ! Looking at the picture , I think what your talking about is a Light ( Red in Color ) Might be ??BRAKE?? But Im not sure I will have to go look ! BAD97Z28CONV; Not in the CORRECT SPOT ?? I'm not sure what to tell you ? ochrisl ; Thanx for the offer But I would like to find out why its lacking an odometer I think its Quite a novelty ! Would be a REAL novelty if it was original dont you think ? Im not convinced that it is But at the same time won't Say its not until I prove it to myself ! until then Ill keep your offer at hand ! Thanx again
Here is a couple of pictures of the outside ! let me know any other details you can think of and try to keep it shorter !
http://hometown.aol.com/natdevris/myhomepage/auto.html



------------------
Nat deVries
70 Camaro 350,4 speed
74 Type LT 350,Auto
Nats70z28 is offline  
post #7 of 19 (permalink) Old May 30th, 00, 05:12 AM
DjD
Retired
Dennis
 
DjD's Avatar
 
Join Date: Apr 1999
Location: Fortuna, CA
Posts: 26,435
Garage
Nat - Wasn't accusing you of editing the picture! Not being familiar with the '70 dash I didn't know if that was an idiot light or ?? The odometer would have to be part of the speedo unless it were digital I would think.

Here is a guess for you. Could the car have been a fleet vehicle and the odometer mounted externaly on a wheel for ease of recording mileage!!!

------------------
...Dennis
Topless'69
[email protected]
DjD is offline  
post #8 of 19 (permalink) Old May 31st, 00, 02:39 PM Thread Starter
 
Join Date: May 2000
Location: Napa,Ca,U.S.A.
Posts: 8
Don't worry Dennis I didnt take it Personal or that you were accusing ! Sorry if I sounded that way ! I was mearly Trying to be Factual not Personal ! Hope this Comes accross that way ! I Have a tendancy to be VERY COLD and INCENCITIVE when I Write ! Don't take ANYTHING I say PERSONAL unless I come right out and say it. Anyway Did the info I gave Help you out any ? Did anybody think of aany thing ??
I Just RE-read your Comments "Dennis" and That idea of being a FLEET Vehichle is one that I have NEVER heard or thought of ! How would I go about Finding out ? And BACK to my original question ! Has anybody ever seen or Heard of this ??
------------------
Nat deVries
70 Camaro 350,4 speed
74 Type LT 350,Auto

[This message has been edited by Nats70z28 (edited 05-31-2000).]
Nats70z28 is offline  
post #9 of 19 (permalink) Old Jun 1st, 00, 02:44 AM
Senior Tech
 
Join Date: Feb 2000
Location: V-burg ms, usa
Posts: 112
uggg!!!

[This message has been edited by 71 Camairo (edited 06-01-2000).]
71 Camairo is offline  
post #10 of 19 (permalink) Old Jun 1st, 00, 02:45 AM
Senior Tech
 
Join Date: Feb 2000
Location: V-burg ms, usa
Posts: 112
I have two early second GEN camaro's and have seen plenty others. In all my days I have never seen let alone heard of such a thing, till now. That is most unusual indeed and interesting.

71 Camairo
71 Camairo is offline  
post #11 of 19 (permalink) Old Jun 1st, 00, 02:56 AM
Senior Tech
 
Join Date: Jul 1999
Location: Balto.,Md
Posts: 188
The 150 mph speedo to the left of the steering column is correct for 70. Normally it should have the odometer right under the center of the speedo. Centered near the bottom is where you should see a small rectangle for the 'BRAKE' indicator.

------------------
1970 mostly original
307,THM350
F41
bowtie-70 is offline  
post #12 of 19 (permalink) Old Jun 1st, 00, 01:50 PM
DjD
Retired
Dennis
 
DjD's Avatar
 
Join Date: Apr 1999
Location: Fortuna, CA
Posts: 26,435
Garage
Nat, I just mentioned the fleet car as food for thought! I can't think of a solid reason it would be without odometer... Does the car have any other odd thing(s) about it? Do you know the previous owner history? One of them might have a great story!

Might get some info from one of the 2nd gen sites or CRG.... Let us know what you uncover.

------------------
...Dennis
Topless'69
[email protected]
DjD is offline  
post #13 of 19 (permalink) Old Jun 2nd, 00, 03:49 AM
 
Join Date: Jun 1999
Location: Bayside, NY
Posts: 19
Have you disassembled your dash yet? It may be that someone in the past has simply removed the odometer and done an excellent job of covering it up. Bondo, light welding or epoxy with some paint can do wonders. You would still be able to see it from the back though. I can't think of one good reason, but that doesn't mean someone didn't do it.

------------------
'69 Base Camaro
355, 200-4R trans
www.midnight-auto.com/yoda
GeorgeK is offline  
post #14 of 19 (permalink) Old Jun 4th, 00, 12:34 AM
 
Join Date: Mar 2000
Location: north east pa. 16428
Posts: 10
Hey Nat, Does the title have milage on it?
scotty dog is offline  
post #15 of 19 (permalink) Old Jun 4th, 00, 09:09 AM Thread Starter
 
Join Date: May 2000
Location: Napa,Ca,U.S.A.
Posts: 8
scotty dog; GOOD Question ! I went and got all my registration papers that i got when I bought the car ! the old Pink slip it was issued in 1991 . To the previous owner under the ODOMETER DATE there is nothing ! Under the ODOMETER READING there is nothing directly under it ! BUT... about 2 lines down there are 2 parallel Lines running horizontal that are 5 digits long kind of like this ===== but about a quarter inch apart from top to bottom. looks like there should be something there ! but its blank ! I also have another older piece of registration issued in 1980 Which also has no Mention of an ODOMETER READING anywhere on it !


------------------
Nat deVries
70 Camaro 350,4 speed
74 Type LT 350,Auto
Nats70z28 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome