looking at buying a 86 2.8camaro - Team Camaro Tech
Tech 2000 Our previous General Forum
Replies ONLY - no new topics.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Apr 1st, 01, 05:39 PM Thread Starter
 
Join Date: Mar 2001
Location: coldlake, alberta, canada
Posts: 4
Question

Is there any knowen problems that I should know about besides lack of hp
StanA is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Apr 2nd, 01, 04:58 AM
Senior Tech
Lance
 
Join Date: Nov 2000
Location: San Jose, CA
Posts: 361
Post

I am the original owner of an '87 2.8. Actually my wife passed it on to me when she got the new car. Got 141k miles. I have done the following. Repainted it in '92, Rebuilt automatic trans at 80K, Water pump, Starter, a/c compressor, replace distributor shaft seal, and three ignition modules. Still runs good. Uses about 1/2-3/4 qt of oil between changes.
Spitfire44 is offline  
post #3 of 5 (permalink) Old Apr 2nd, 01, 05:49 AM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,623
Garage
Cool

My daughter has an '87 S-15 w/2.8L V6 auto.
141K miles, runs good, no major/minor problems except replaced water pump.

But if you buy it, don't complain about lack of power, you already know this.

Everett 68/350/PG/11.90/115mph
Everett#2390 is offline  
 
post #4 of 5 (permalink) Old Apr 2nd, 01, 05:50 AM Thread Starter
 
Join Date: Mar 2001
Location: coldlake, alberta, canada
Posts: 4
Talking

Thanks for the info Spitfire44 I'm kind of new to the sports car field couldn't afford one for the longest time now I'm looking to restore this one again thanks
StanA is offline  
post #5 of 5 (permalink) Old Apr 2nd, 01, 04:37 PM
 
Join Date: Mar 2001
Location: washington
Posts: 6
Post

Just to let you know,the replacement 2.8 is very expensive and hard to find(in washington anyways)they supposely have "soft" cranks, got one in a 86 with 167,000 miles on it still runs great.
BlueRoc is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome