Part throttle dilemma - Team Camaro Tech
Tech 2000 Our previous General Forum
Replies ONLY - no new topics.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Jun 9th, 01, 03:09 PM Thread Starter
 
Join Date: May 2001
Location: Poquoson, va
Posts: 25
Post

I have a 406 with 10 to 1 compression, Trick Flow heads, Performer Intake, General Kinetics 268 cam, recurved HEI distributor,headers and dual exhaust, 2400 stall, and 3.42 posi, all in a 78 Camaro. My problem is my part throttle response seems soggy. Full throttle the car will scream but part throttle it seems like I have to press the throttle further than I should need to to accelerate. I have tried several carbs and 2 different distributors, but no change. Any suggestions are greatly appreciated.
78lt is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Jun 9th, 01, 05:11 PM
Moderator
David Pozzi
 
davidpozzi's Avatar
 
Join Date: Nov 1999
Location: Central California, USA
Posts: 10,061
Post

Make sure your mechanical advance is all in by 2500 or so.
If the mech advance comes in too slowly, it will make the mid range sluggish.
On an HEI the weights would have to have the finger end opposite the weight trimmed down a bunch to come in that quickly.
Also watch for the advance freezing up due to corrosion on these distributors.
David

------------------
Check my web page for First Gen Camaro suspension info:
David's Motorsports page
First Gen Suspension Page
67 RS 327
69 Camaro Vintage Racer
65 Lola T-70 Chev 350 Can-Am Vintage Racer
davidpozzi is offline  
post #3 of 4 (permalink) Old Jun 10th, 01, 10:59 PM
Senior Tech
 
Join Date: Jan 2001
Location: skiatook, ok
Posts: 3,692
Post

What kind of carb are you running? May just need some fine tuning.

------------------
375hp 78 Chevy truck
77 Chevy Nova
95 Chevy Lumina 3.4L
and building a 78 Nova
travis is offline  
 
post #4 of 4 (permalink) Old Jun 12th, 01, 01:36 PM Thread Starter
 
Join Date: May 2001
Location: Poquoson, va
Posts: 25
Post

OK I got everything sorted out. I had an Edelbrock 750 on it. I tried a freshly rebuilt QJet jetted to 396/350 specs and the car will scream now. Thanks heaps
78lt is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome