Anyone own a 1968 camaro 350 vin #301678? - Team Camaro Tech
Tech 2000 Our previous General Forum
Replies ONLY - no new topics.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old May 2nd, 01, 05:24 PM Thread Starter
Gold Lifetime Member
Tim
 
Join Date: Feb 2001
Location: The Mountain West
Posts: 454
Question

I have the original block and heads for this car.

IT was built VO0828MS
Aug. 28th of 1967 in Los angeles.

Tim

------------------
ratchetmaster
1968 RS SS 350
1968 RS pro street project
1972 454 ElCamino
1973 RS LT Z28 Camaro M4
1999 Firebird WS-6 T/A
moderator http://www.gmforums.com
ratchetmaster is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old May 7th, 01, 02:40 PM Thread Starter
Gold Lifetime Member
Tim
 
Join Date: Feb 2001
Location: The Mountain West
Posts: 454
Post

ttt
ratchetmaster is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome