TACH NOT WORKING - Team Camaro Tech
Tech 2000 Our previous General Forum
Replies ONLY - no new topics.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Oct 29th, 00, 01:28 AM Thread Starter
J85
 
Join Date: Oct 2000
Posts: 3
Talking

I have a tach for a 67 camaro and I'm trying to install it in my car. I have made the changes to the wiring harness and it is hook up correctly, but it doesn't work. I have taken my tach/dwell meter and hooked it up to the the dash harness and it works. The tach was hooked up to the coil and it didn't work. So I'm pretty sure the tach is broken. I have and HEI distributor, would that make a difference? I don't think it should. Any one know who can repair tachs?
J85 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Oct 29th, 00, 08:52 AM
Tech Team
 
Join Date: Aug 2000
Location: winters, CA, Us
Posts: 73
Cool

As weird as it seems check the radio fuse. I installed a tach on my 68 and I was installing a stereo.. the radio fuse blew and my tach stopped working, replaced the fuse and it worked.. check that,, good luck
tireblazin68 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome