carb or exhaust backfire - Team Camaro Tech
Tech 2000 Our previous General Forum
Replies ONLY - no new topics.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Oct 30th, 00, 03:40 AM Thread Starter
 
Join Date: Oct 2000
Posts: 10
Post

I have a "popcorn" sounding popping noise coming from my exhaust system, only when I let off the gas. Not when accelerating. I have no obvious exhaust leak, but sometimes getting a smell possibily from a "too rich" running carb. I have a 650 holley four barrel on a 350 67 Camaro. I brought the car down to a friends garage, put it on the computer and adjusted the mixture, it seemed to work for about 5 miles down the road and then started back, popping. Any ideas??
Barry67 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Oct 30th, 00, 05:22 PM
J85
 
Join Date: Oct 2000
Posts: 3
Post

When the engine backfires on deacceleration it is usually an exhaust leak. If you have headers thats the best place to look for a leak. I also find holloy carbs really tempermental, when they work they work great, but you are always adjusting. <BLOCKQUOTE>quote:</font><HR>Originally posted by Barry67:
I have a "popcorn" sounding popping noise coming from my exhaust system, only when I let off the gas. Not when accelerating. I have no obvious exhaust leak, but sometimes getting a smell possibily from a "too rich" running carb. I have a 650 holley four barrel on a 350 67 Camaro. I brought the car down to a friends garage, put it on the computer and adjusted the mixture, it seemed to work for about 5 miles down the road and then started back, popping. Any ideas??<HR></BLOCKQUOTE>

J85 is offline  
post #3 of 4 (permalink) Old Oct 30th, 00, 08:05 PM
Tech Team
 
Join Date: Aug 2000
Location: winters, CA, Us
Posts: 73
Cool

Check for exhaust leaks.. I know I have an exhaust leak and my car does it really bad. My carb isn't rich either so check for exhaust leaks. Are you running headers or manifolds? good luck
tireblazin68 is offline  
 
post #4 of 4 (permalink) Old Oct 30th, 00, 09:36 PM
Senior Tech
 
Join Date: Oct 2000
Location: odessa,texas,unitedstates
Posts: 117
Post

u probably had to much gas and gas fouled your plugs change your plugs thatll fix it probably cause if it is popping out of the carberator its not firing right it comes out the carberator cause thats the only way out my guess is a plug.
camaro79tx is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome