I posted this under Engine & Drivetrain but... - Team Camaro Tech
Tech 2000 Our previous General Forum
Replies ONLY - no new topics.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Jul 12th, 01, 06:59 AM Thread Starter
Senior Tech
 
Join Date: Oct 2000
Location: CT
Posts: 389
Post

since not everyone needs to go to that forum I'll post it here as well...

What do ya' think of a Lingenfelter 383 LT1 Engine Package in a 69??? How difficult would it be to get this into a 69 SB car?
I am planning on rewiring the car, prob go with M&H. Planning on a TH350 but may go w/ a 400 and will use a 3.73 12 bolt posi.

Thanks for your thoughts!

Rob
RFrenette is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Jul 12th, 01, 11:49 AM
Senior Tech
 
Join Date: Mar 2001
Location: Niceville Fl
Posts: 1,070
Post

it shouldn't be too hard I have see plenty of LS1's in first gen camaros. I have never done it but I know it an be done

------------------
69 Camaro RS, 355ci, 72 gm casting heads,mild cam, Preformer rpm intake, edelbrock 600 carb, 350 turbo w/ shift kit 2500 stall, 10 bolt 2.73 any more questions ask
69CamaroRacer is offline  
post #3 of 4 (permalink) Old Feb 14th, 02, 03:27 PM
Gold Lifetime Member
Peter
 
Join Date: Jun 2001
Location: New Jersey
Posts: 364
Talking

69CamaroRacer,

I'd like to learn more about the LS1/T-56 swap into a first gen. Do you know anyone who could share information?

Peter
coach420 is offline  
 
post #4 of 4 (permalink) Old Feb 15th, 02, 11:41 AM
Senior Tech
Jeff
 
Join Date: Jun 1999
Location: Ewing, NJ 08560
Posts: 2,438
Post

Go over to www.camaroz28.com and check out the Classic Tech forum and you'll see lots of questions about the swap. Tyler Beauregard (aka TeeToe Jones) has a kit for swapping in the T56 and he's done the LT1 as well. I think he lurks on this board sometimes, but there's more people over there that have done the swap.

------------------
Jeff H - 93 Indy 500 Pace Car(supercharged) & driven daily, Hugger Orange 69 Z28 with JL8 brakes, cross-ram & GM fiberglass hood, TI setup, heater and radio delete, being restored
Jeff H is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome