Power Steering - Team Camaro Tech
Tech 2000 Our previous General Forum
Replies ONLY - no new topics.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Oct 12th, 99, 03:03 AM Thread Starter
 
Join Date: Sep 1999
Posts: 6
We recently converted my '68 (350) from manual to P/S. The steering seems fine when driving down the road but if I am not putting my foot on the gas/ accelerating it is extremly difficult to turn the wheel-such as backing out of the driveway, etc. I've re-checked the belt's tightness but nothing seems to remedy this odd situation-Anybody got any ideas or experience with this?
68327 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Oct 12th, 99, 11:36 AM
 
Join Date: Jun 1999
Posts: 306
Could be one of two things. The steering box is not bled properly or the pump is on its way out. To bleed the box after initial installation raise the front of the car so the whells are off the ground. Start the car and turn the wheel lock to lock several times while checking the level of fluid in the pump. Add fluid as needed. If the car had been run for some time without fluid in the pump that could have burned out the pump. If its a used pump then it could just be worn out.

Hope this helps

Joseph

[This message has been edited by Joseph (edited 10-14-99).]
Joseph is offline  
post #3 of 3 (permalink) Old Oct 14th, 99, 03:01 PM Thread Starter
 
Join Date: Sep 1999
Posts: 6
Thanks! I'll give your suggestion a try.
68327 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome