oil Cooler - Team Camaro Tech
Tech 2000 Our previous General Forum
Replies ONLY - no new topics.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Apr 20th, 01, 09:13 AM Thread Starter
 
Join Date: Aug 2000
Location: franklin,ma
Posts: 16
Post

I just installed a oil cooler and remote filter kit from Summit. I installed a K&N filter, and there are no kinks in the oil hoses. My oil pressure dropped from 60 to 30 psi at idle. It now takes about 10 sec to develop oil pressure at start up. The pressure climbs very slowly with engine revs. Am I doing more harm than good? I want to remove it, what do you think?
RIFRY is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Apr 20th, 01, 10:33 AM
Senior Tech
 
Join Date: Jul 2000
Posts: 170
Post

I know this may sound like a stupid question, but did you add extra oil to make up for the volume that is now in the cooler and lines? all that oil does not usually return to the sump...so therefore there is less oil in the sump when you start it up. Maybe you do not have to add extra but it makes sense to me that if a the lines and tubing would hold a quart of oil then that is one less quart that is in the sump. check the dipstick.
jblake is offline  
post #3 of 3 (permalink) Old Apr 20th, 01, 12:36 PM Thread Starter
 
Join Date: Aug 2000
Location: franklin,ma
Posts: 16
Post

Yes I had to add about a quart and a half extra.
RIFRY is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome