Accelorator Pedal Install??? - Team Camaro Tech
Tech 2000 Our previous General Forum
Replies ONLY - no new topics.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old Jun 20th, 01, 09:44 AM Thread Starter
 
Join Date: Jun 2001
Location: Colden, NY, USA
Posts: 3
Angry

Fella’s and Ladies (I had to stick that in there because my wife saw a post I made when I only acknowledged the fella’s – and it was not pretty, believe me),

This should be an easy one. I am attempting to install an accelerator pedal pad on my 69 Camaro. The car went through a full restoration a few years ago. I purchased it a couple of weeks ago. I am not the most technically inclined when it comes to mechanics – but this should be a no brainer (I thought). The arm for the pedal is rounded at the end that faces the driver. No holes in it to stick pin through. I also have a spring - I can see how the spring would push against the arm.

I have not ruled out that the shaft for the accelerator pedal does not belong on the car – if that is true, does anybody recognize what it belongs on? This way I can at least find a pedal to match it.

Thanks all for you help with this,
David.


------------------
1969 Camaro 454
2001 Trans-Am Ram Air
ToyPics
Colden69 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old Jun 20th, 01, 06:05 PM
Gold Lifetime Member
 
stevo camaro's Avatar
 
Join Date: Mar 2000
Location: Dunsmuir, CA
Posts: 1,969
Garage
Post

I don't believe they pin in the back, but I'm not 100% sure. I don't remember pinning mine or anything being behind it. Mines a 67, I'll have to look again.

------------------
Steve
67 SS 396,4-sp
67 RS 327,4-sp
72 RS 350/350
69 4X4 suburban 350,4-sp
73 3/4 ton 454/400
Stevo Camaro's Toy
Our Muscle Cars
stevo camaro is offline  
post #3 of 9 (permalink) Old Jun 20th, 01, 06:08 PM
Gold Lifetime Member
Charley
 
clill's Avatar
 
Join Date: Nov 1999
Location: Woodland, Ca.
Posts: 3,533
Garage
Post

Yes there has to be a hole. You must have the wrong one.
clill is offline  
 
post #4 of 9 (permalink) Old Jun 21st, 01, 05:03 AM
Tech Team
 
Join Date: May 2001
Location: Athens Alabama
Posts: 60
Post

i agree, there IS a hole for the pin. but it still is a frustrating task
68SS350something is offline  
post #5 of 9 (permalink) Old Jun 21st, 01, 10:52 PM
Senior Tech
Donnie
 
Join Date: Apr 2001
Location: Clarksville, Tennessee, U
Posts: 233
Send a message via MSN to 69DZ302
Cool

I just replaced the trim on my '69 Z28 gas pedal and yes it has to have the hole for the pin and spring. I'm having a time getting it all back together. I looked it up in my Assembly Manual and it showed a picture of how it goes back so maybe with some luck I can get it installed. Good luck. Donnie (1969 Fathom Green stock Z28)
69DZ302 is offline  
post #6 of 9 (permalink) Old Jun 22nd, 01, 02:40 AM Thread Starter
 
Join Date: Jun 2001
Location: Colden, NY, USA
Posts: 3
Post

Thanks all for the information. It sounds like I have the wrong arm for it. Before I wear a hole in another pair of shoes, I will head down to Camaro Specialties and find a new one. I am going to order a new assembly manual, the one I have is an ebay special and not much help. Any suggestions, I plan on ordering something via. Amazon.com through this website.
Thanks again all,
David.
Colden69 is offline  
post #7 of 9 (permalink) Old Jun 22nd, 01, 07:02 AM
Senior Tech
John
 
Join Date: Sep 2000
Location: Orchard Park, NY USA
Posts: 717
Post

Colden, Welcome to the site! I see you live in my back yard (I live in O.P.) Bob probably has the manuals in stock. Will you have your car ready for the WCA eastern Nats in July at U.B?

John
John Doyle is offline  
post #8 of 9 (permalink) Old Jun 22nd, 01, 07:12 AM Thread Starter
 
Join Date: Jun 2001
Location: Colden, NY, USA
Posts: 3
Post

Hi John,
This is the first I've heard of the WCA, this is my first classic car. Is that some type of local club - I have been thinking about joining one. Either way, I will try to attend.
Thanks for the information, hope to see you around.
David.
Colden69 is offline  
post #9 of 9 (permalink) Old Jun 22nd, 01, 11:35 AM
Senior Tech
John
 
Join Date: Sep 2000
Location: Orchard Park, NY USA
Posts: 717
Post

David, Unfortunately there isn't a local chapter. Here's the link;
www.worldwidecamaro.com

John
John Doyle is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome