Where did everyone go? - Team Camaro Tech
Bench Racing Stories, cruising and more.

 82Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 88 (permalink) Old Oct 13th, 19, 09:07 PM Thread Starter
Senior Tech
Chris
 
Join Date: Jun 2003
Location: Pocono Mountains Pa.
Posts: 2,565
Where did everyone go?

Hey everyone. I haven't been around here much since I finished my cars resto. It seems everyone has left. This place used to be really buzzing with dozens of new posts a day. If you posted a question you'd have an answer in minutes.Seems it's a ghost town now. Where did everyone go? Don't see many regulars around anymore.
Anyway here's a few pics of my 68 finished. It was a ground up resto that took me 10 years. Every nut,bolt and screw, done all by myself, paint, body, interior, suspension, alone in my 2 car garage.



ckaram, HawkX66, DaveS44 and 4 others like this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
shoddy_F-body is offline  
Sponsored Links
Advertisement
 
post #2 of 88 (permalink) Old Oct 13th, 19, 09:47 PM
Senior Tech
Al
 
Join Date: Jun 2007
Location: Iowa
Posts: 3,360
Re: Where did everyone go?

Nice work Chris. Beautiful car. I remember when you were a regular here. Like you I think
a lot of guys have finished their cars and just don't have a reason to visit the site. We've seen a
lot of people post a few questions, get their answers and disappear. Also so many questions have
been answered over the last 5 or more years I think people are searching for the answers rather than
posting which I think is good. A few years ago there were a number of builds going on where the
guys (myself included) were bouncing questions and answers off each other. I haven't seen much
at all for new builds in a long time. The build and body shop forums were a buzz at that time. I
question just how many builds are really going on anymore. There seems to be a lot of engine
ignition and suspension questions most recently. I finished my build (if they're ever finished) earlier
this year but still hang around trying to help and continue to learn.
shoddy_F-body and 350sshugger like this.

Al

my 67' build thread:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
allanjs is offline  
post #3 of 88 (permalink) Old Oct 13th, 19, 09:52 PM
Team Member
Darin
 
ilikeike's Avatar
 
Join Date: Jun 2013
Location: Stanislaus Co. Ca.
Posts: 1,428
I asked you some questions a few years ago in my build thread, but you never answered...
Just kidding,

but that’s what happened, everyone went to the gossip page. forums are done. although I prefer forums over facebook . I don’t do facebook didn’t do MySpace either. i just don’t get it, F-book just doesn’t work for me, it just seems like a rambling post like this...:]
,
shoddy_F-body and Hgger69 like this.

1968 Butternut Coupe,
421" Dart SHP block
TKO 600 RR
Dutchman 9" w/3.70 US Gear Lightning r&p
Speedtech torque arm,Ridetech HQ coilovers
Global West arms
Budnik wheels

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by ilikeike; Oct 13th, 19 at 10:42 PM.
ilikeike is offline  
 
post #4 of 88 (permalink) Old Oct 14th, 19, 12:33 AM
Senior Tech
Alex
 
Join Date: Aug 2016
Location: Bakersfield, CA
Posts: 132
Re: Where did everyone go?

Yeah, I don't get why people try and use a site like FB as forums, it makes zero sense. You can't search a forum archive for info, it's nearly impossible to browse so the same question must be asked over and over again. Plus it's only been around 1/3 as long as forums.

That said, it is happening.
shoddy_F-body likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Pontiac Firebird
w/BP 461ci stroker kit, 670 heads & XE274H cam. Primer black w/black interior.
1992 Pontiac Trans Am GTA w/SLP Performance Package. Dark Jade Grey Metallic, grey leather, T-Tops.
anguilla1980 is offline  
post #5 of 88 (permalink) Old Oct 14th, 19, 12:58 AM
Senior Tech
Tim
 
Join Date: Mar 2011
Location: Australia
Posts: 3,610
Re: Where did everyone go?

Chris, your car turned out awesome - well done!
You may need to change your user name now though, that car's far from shoddy
shoddy_F-body likes this.

1969 04A Van Nuys-built Z/28. Cortez Silver with dark blue interior and VE3. Sold Clippinger Chevrolet. Raced at Lions in LA.
ZLP955 is offline  
post #6 of 88 (permalink) Old Oct 14th, 19, 04:26 AM
Senior Tech
Brian
 
Join Date: May 2005
Location: Laurel, In
Posts: 4,903
Re: Where did everyone go?

I'm still here. There comes a point in every forums life where most of the regulars get a thorough education and just don't have as many questions as before. Plus about every conceivable question that can be asked about a first gen has already been asked and answered.
shoddy_F-body likes this.

Experience...... It's what you get when you didn't get what you wanted.
buenymayor is offline  
post #7 of 88 (permalink) Old Oct 14th, 19, 05:16 AM
Gold Lifetime Member
Matt
 
Join Date: Apr 2013
Location: Michigan
Posts: 1,129
Re: Where did everyone go?

Beautiful job Chris. I remember your build going on here.

I think like has been stated above that the number of massive build projects has dwindled. Seems like there were about 10 of us working big projects for a while, and some of us are completed or nearing completion. Others disappeared; possibly getting burned out for a bit. I also do a lot of searching before posting for an answer. There is a ton of information on here.....if you can find it.

I think the other big problem was the photosuckit disaster. That destroyed a lot of good information. If I have any gripes with this site, it is the picture sharing. To preserve information the picture sharing needs to be corrected.
shoddy_F-body, HawkX66 and allanjs like this.

My Build Thread


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
350sshugger is offline  
post #8 of 88 (permalink) Old Oct 14th, 19, 06:01 AM
Team Member
Don
 
Join Date: Jun 2006
Location: Mountain Springs, Texas
Posts: 3,606
Re: Where did everyone go?

The need to have a paid membership to post pics is slowly killing this forum imho. New members get discouraged right out of the gate when they canít post a pic. I belong to quite a few forums and this is the only one that has this restriction on pic posting. Forum owners are killing their own forums.

Don
shoddy_F-body, DT, HawkX66 and 6 others like this.

1969 Camaro LSA 6L90E AME subframe and IRS
1969 Camaro vert LS3 4L65E Ridetech level 2 - sold
1959 El Camino project
1969 Mustang Sportsroof project
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1956 Cameo project - C5 drivetrain
1957 Buick Caballero project
dhutton is offline  
post #9 of 88 (permalink) Old Oct 14th, 19, 07:04 AM
Gold Lifetime Member
Tony
 
Join Date: Jan 2013
Location: Mobile AL
Posts: 1,638
Re: Where did everyone go?

My god Chris, that car is beautiful..
Just speaking for myself, I took a step back from Camaro building to get recharged and to do some home improvements and to heal from an accident. Ready to get back to work...!
shoddy_F-body likes this.

Tony
Follow my current Camaro project builds...
1967 Coupe (Sold)

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1968 Convertible

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Convertible
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
bondora68 is offline  
post #10 of 88 (permalink) Old Oct 14th, 19, 08:23 AM
Gold Lifetime Member
Andrew
 
Andrew69's Avatar
 
Join Date: Nov 2002
Location: Greenwood, SC
Posts: 5,636
Re: Where did everyone go?

Chris, your car looks great. Well done!

I remember the past discussions of how to replace a quarter panel and other detailed concerns. Those rarely happen anymore, as I guess anyone needing this info now finds it with a search. Also, many members are getting older and may be losing interest. I surf the contents daily but find I post much less frequently than I used to.
shoddy_F-body likes this.

Skunk Works
302DZ, M22W Muncie, GV overdrive,12-Bolt Rear 3.73
Some photos:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Member # 159
Andrew69 is online now  
post #11 of 88 (permalink) Old Oct 14th, 19, 08:46 AM Thread Starter
Senior Tech
Chris
 
Join Date: Jun 2003
Location: Pocono Mountains Pa.
Posts: 2,565
Re: Where did everyone go?

Thanks guys. Nice to see some familiar names! I'm Friends with Jim Mellema on Facebook. He was a regular, He sold his blue 68 and travels the country in a motorhome which is pretty awesome.I do wonder if a lot of the die hards of this hobby are aging out. I was in my late 20's early 30's when I discovered this site and Chevelles.com ( I have a 70 Chevelle also) I actually bought my Camaro from a member on there, Maiden70 or something like that up in Poukeepsie NY. Not sure if he's still around. Now I'm nearing 50 and don't know if I have it it me for any more restorations. I'm enjoying tinkering with my completed cars. Although I have been watching a 67 convertible Camaro that's for sale locally that would be a very big project.
Anyway here is a before pic from the Ebay ad that I bought my car from. Quite amazing to me to see it now!


and an "in progress" pic

HawkX66 likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by shoddy_F-body; Oct 14th, 19 at 03:57 PM.
shoddy_F-body is offline  
post #12 of 88 (permalink) Old Oct 14th, 19, 09:49 AM
Gold Lifetime Member
Roger
 
rogerh's Avatar
 
Join Date: Oct 2004
Location: Quincy, IL
Posts: 18,700
Re: Where did everyone go?

Personally I get discouraged in answering post because the OP doesnít give us the information we need. I have went to the garage and taken pictures of a part on my 67 to answer a post just to find they are working on a 69. Then you can knock yourself out finding the information and get no reply at all.

Roger
shoddy_F-body, HawkX66 and allanjs like this.

1967 Camaro SS/RS 350/295HP Coupe. First and only owner.

Last edited by rogerh; Oct 14th, 19 at 12:27 PM.
rogerh is offline  
post #13 of 88 (permalink) Old Oct 14th, 19, 10:09 AM
Senior Tech
Brandon
 
Join Date: May 2004
Location: Monroe, NC
Posts: 2,089
Garage
Re: Where did everyone go?

Nicely done Chris, So true, not alot of the a$$ busters here that used to be. I think alot left after pdq67 got thrown out the door.
shoddy_F-body likes this.

Brandon J. licence 1NASTY67

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Nantooch is offline  
post #14 of 88 (permalink) Old Oct 14th, 19, 11:07 AM
Senior Tech
Al
 
Join Date: Jun 2007
Location: Iowa
Posts: 3,360
Re: Where did everyone go?

Quote:
Originally Posted by rogerh View Post
Personally I get discouraged in answering post because the OP doesnít give us the information we need. I have when to the garage and taken pictures of a part on my 67 to answer a post just to find they are working on a 69. Then to you can knock yourself out finding the information and get no reply at all.

Roger
I don't go to the lengths I once did either for these same reasons. It gets rather irritating when the OP
doesn't acknowledge an answer or reply to a question (more info needed). Often I link a previous thread
that answers the question. No need to beat a dead horse reiterating the info. Also as Matt said the Photobucket
crap has hurt. And to Dons point not being able to simply drag and drop a pic is a pita especially for those
that have never had to work around that. Wait until the the ad blockers stop working and the site will virtually
die. That's already happened to me on another site. That will drive people to facebook or similar.
HawkX66 likes this.

Al

my 67' build thread:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
allanjs is offline  
post #15 of 88 (permalink) Old Oct 14th, 19, 12:22 PM
Senior Tech
 
Join Date: Nov 2018
Posts: 920
Re: Where did everyone go?

OP, very nice build

Well I may be considered a FNG as I have only been a member about a year now. Have been a forum member on another car type site for 20 years and it is a shell of what it once was. Seems they all have a life compared to their fast & furious days. I still cruise a few car forums daily and enjoy it

Seems FB is the go to for car chat but I don't do SM

I would be lost without the help of those who do still reply/post on several things with my 67

Also disappointed on the picture post thing and photopuke has killed countless photos on this and other forums. For this and other forums with restrictive pic post policy I use https://postimages.org/login which works well but is a PIA as you first need to post the pic on that site them copy/paste a thumbnail link on this one but at least it works.
shoddy_F-body likes this.
SoCal805 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome