emblem placement - Team Camaro Tech
Body Shop Paint & Body Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Sep 6th, 18, 06:35 AM Thread Starter
Gold Lifetime Member
Ben
 
Join Date: Mar 2016
Location: Delaware
Posts: 274
Garage
emblem placement

just had car re-painted and replaced both front fenders. i got new emblems as well. i bought the templates and the body shop used them for placement but the crossed flag emblem seems too low under the camaro emblem. i used to have the bigger crossed flags for the big block cars with the turbo jet engine call out on the old fenders. they were closer to the camaro emblem but they were also bigger. this time i just went with the standard V8 crossed flags and no engine call out. does it look right? if not, there isn't much i can do.....just curious. alos, i realize the pictures make them look a little crooked...maybe it's just me, but i assure you they are not. must be the reflections
Attached Thumbnails
Click image for larger version

Name:	20180809_130053.jpg
Views:	31
Size:	230.1 KB
ID:	221271   Click image for larger version

Name:	20180825_164618.jpg
Views:	32
Size:	440.3 KB
ID:	221273  

Last edited by bhodgdon400; Sep 6th, 18 at 06:53 AM.
bhodgdon400 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Sep 6th, 18, 07:06 AM
Senior Tech
Robert
 
Join Date: Jul 2005
Location: Elizabeth, Colorado
Posts: 391
Garage
Re: emblem placement

It looks correct to me, but I am not an expert on 67s. Do you still have the old emblems? You could hold it up to compare.

AKXtreme
69 Camaro L48 SS350
M20 4spd
akxtreme is offline  
post #3 of 5 (permalink) Old Sep 6th, 18, 08:15 AM Thread Starter
Gold Lifetime Member
Ben
 
Join Date: Mar 2016
Location: Delaware
Posts: 274
Garage
Re: emblem placement

still have old emblems but they were on old fenders and they were the bigger big block emblems with 427 Turbo jet. bigger emblems overall
Attached Thumbnails
Click image for larger version

Name:	20160306_142157.jpg
Views:	10
Size:	270.7 KB
ID:	221275  
bhodgdon400 is offline  
 
post #4 of 5 (permalink) Old Sep 6th, 18, 08:29 AM
Senior Tech
Al
 
Join Date: Jun 2007
Location: Iowa
Posts: 2,882
Re: emblem placement

Here's my originals. Not a BB but maybe it'll help.




Al

my 67' build thread:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
allanjs is online now  
post #5 of 5 (permalink) Old Sep 6th, 18, 10:14 AM Thread Starter
Gold Lifetime Member
Ben
 
Join Date: Mar 2016
Location: Delaware
Posts: 274
Garage
Re: emblem placement

it does help. i think mine are right in the same place. thank you. i chose not to include the 327 or any engine call out so it looks like the flags on yours are in the same location in respect to the camaro emblem. i guess it just looked off to me after having the other ones on it for a while
bhodgdon400 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome