C6 Corvette temperature guage not working - Team Camaro Tech
Non-Camaro Tech Problems and Issues with your daily driver or other non-Camaro vehicles.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old Oct 31st, 12, 07:29 AM Thread Starter
Donatocantu can
 
Join Date: Oct 2012
Location: Laredo tx
Posts: 3
C6 Corvette temperature guage not working

i own a 2008 chevy corvette i recently changed the thermostat to a 160 degree thermostat i was driving it yesterday and hit a dip the temperature guage stopped working and the car began to display on the dash "engine hot turn off A/C" but car was fine not hot at all and working fine drove it for a bit stopped removed battery and everything went back to normal!! today it is doing it again but nothing is wrong with car except for temp gauge not working and that message on dash
Doncan is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old Oct 31st, 12, 07:30 AM Thread Starter
Donatocantu can
 
Join Date: Oct 2012
Location: Laredo tx
Posts: 3
Re: c6 corvette temperature guage not working

any ideas what it could be??
Doncan is offline  
post #3 of 6 (permalink) Old Oct 31st, 12, 09:42 AM
Gold Lifetime Member
John
 
Vintage 68's Avatar
 
Join Date: Mar 2002
Location: Moraga,Ca.,USA
Posts: 13,705
Wink Re: C6 Corvette temperature guage not working

The Gauge in the IPC gets it's information/signal from the PCM.
The PCM gets it's info from the CTS (Coolant Temp. Sensor) located in the Left(Drivers) side Head.
The PCM sends it's serial buss data through the DLC (data link connector) system between the two 'boxes' via terminal #58 from the PCM to terminal #A11 on the IPC (instrument panel cluster) input.

Soooo - you either have a bad connection at the CTS, in the wiring to the PCM or in the wiring to the IPC ...

I'd really recommend you get the correct SERVICE manual from GM for your vehicle if you intend to start fixing these type of system issues.
The days of just changing out a sensor or finding an easy wiring/connector issue are gone - you need to understand the actual metrology/methodology paths on newer vehicles to fix what were once 'simple' problems
You need the exact schematics and information for YOUR vehicle to stand a chance at tracing this stuff down.

Hope this helps.

1968 Convertible
Some trucks
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Other V8 things - some of which float
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Other V6 things - none of which float
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Oh yeah, and 1 "Straight-Six" ...
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


If a man says something in the garage - and his wife can't hear him - is he still wrong !!!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Vintage 68 is offline  
 
post #4 of 6 (permalink) Old Oct 31st, 12, 12:20 PM Thread Starter
Donatocantu can
 
Join Date: Oct 2012
Location: Laredo tx
Posts: 3
Re: C6 Corvette temperature guage not working

I have been researching this all day and what i have heard from several places is that my cars computer has a sensor that monitores the coolant temp and level and if it is not heating up fast enough or too fast it will send out all these codes now my ac is not cooling which i read is also done by these codes yest when i disconnected the battery everything went back to normal till today so guess i have to go back to my old thermostat
Doncan is offline  
post #5 of 6 (permalink) Old Oct 31st, 12, 01:07 PM
Gold Lifetime Member
John
 
Vintage 68's Avatar
 
Join Date: Mar 2002
Location: Moraga,Ca.,USA
Posts: 13,705
Wink Re: C6 Corvette temperature guage not working

Quote:
Originally Posted by Doncan View Post
... i have heard from several places is that my cars computer has a sensor that monitores the coolant temp ...
... if it is not heating up fast enough or too fast it will send out all these codes now my ac is not cooling which i read is also done by these codes ...
... guess i have to go back to my old thermostat
It's all 'Codes' now son (with apologies to Chevy Chase)

I really doubt the thermo is actually causing the issue.
Heating 'slow'
The cold-soak to OT slope will still be the same, as far as the CTS is concerned, with a 'colder' thermo - and the edge clock of the PCM is not that 'tight'. It would need to have a decently forgiving range to assure proper response in very cold weather.
Just the full flow operation timing will be effected.

It is very easy to disturb wiring and connectors when moving it out of the way - like when changing a common part ...

Disconnecting the Battery (or better yet, just pulling the PCM fuse(s) ) is just re-setting an 'iffy' data memory - not fixing anything.
The next cycle(s) will see the issue an set that issue response again i and again - and ... until you locate issue and address it.

My money is still on an issue with wiring/connector(s) between the CTS and the PCM
No/low reference signal to the PCM from the CTS would cause the problem you're seeing ...

But what do I know ...

1968 Convertible
Some trucks
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Other V8 things - some of which float
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Other V6 things - none of which float
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Oh yeah, and 1 "Straight-Six" ...
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


If a man says something in the garage - and his wife can't hear him - is he still wrong !!!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Vintage 68 is offline  
post #6 of 6 (permalink) Old Nov 1st, 12, 03:51 AM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,590
Garage
Re: C6 Corvette temperature guage not working

Excellent info! More like a 'fail-protection' system - turn off those ancillary systems to keep the power plant running.
Remember, quiz on Friday...

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - maybe this year, 2019 ...
Everett#2390 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome