My 09 avalanche troubles - Team Camaro Tech
Non-Camaro Tech Problems and Issues with your daily driver or other non-Camaro vehicles.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Dec 22nd, 12, 12:36 AM Thread Starter
Gold Lifetime Member
Steven
 
stamatisg1977's Avatar
 
Join Date: Sep 2005
Location: Mastic Beach Village, NY
Posts: 2,983
My 09 avalanche troubles

Hey guys. On my way to work tonite my truck started bucking real bad and luckily I keep my scanner tool in the center console. I pulled code p0087 which is a low fuel rail pressure and another code that I think said fuel pump driver module. Anyway driving under load the fuel psi will read between 44-56 psi. But with the engine off/key on it climbs all the way up to 80psi. I took it for a quick spin when I could as it still bucked and hesitated under load, it did not drop any codes. Your thoughts??

I'm at work and scared to drive home in the morning lol

69 Frost Green Camaro
LS3 with TSP stage 3 cam
Tremec TKO 600
Moser 12 bolt rear with ford ends 3.73:1 Eaton tru trac differential
Speedtech pro touring subframe
Ridetech rear 4-Link


Follow my journey here:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
stamatisg1977 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Dec 22nd, 12, 07:50 AM
DjD
Retired
Dennis
 
DjD's Avatar
 
Join Date: Apr 1999
Location: Fortuna, CA
Posts: 26,436
Garage
Re: My 09 avalanche troubles

Just based on your description ir sounds like the fuel pump is bad...

...Dennis

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


"Don't take life so serious, you won't get out alive..."
DjD is offline  
post #3 of 5 (permalink) Old Dec 22nd, 12, 03:25 PM Thread Starter
Gold Lifetime Member
Steven
 
stamatisg1977's Avatar
 
Join Date: Sep 2005
Location: Mastic Beach Village, NY
Posts: 2,983
Drove it again today and I was watching the fuel pressure and it didn't go over 45 psi even under hard acceleration

69 Frost Green Camaro
LS3 with TSP stage 3 cam
Tremec TKO 600
Moser 12 bolt rear with ford ends 3.73:1 Eaton tru trac differential
Speedtech pro touring subframe
Ridetech rear 4-Link


Follow my journey here:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
stamatisg1977 is offline  
 
post #4 of 5 (permalink) Old Dec 22nd, 12, 04:18 PM
Senior Tech
Paul B
 
Join Date: Jul 2012
Location: Ontario
Posts: 273
Re: My 09 avalanche troubles

I think some of these vehicles had a problem with a flexible part of the fuel lines collapsing under load, which triggers the Poo87 code. Might be a TSB on it as well. Getting 80psi at idle and dropping to 44psi indicates a restriction or blockage. Fuel pressure regulator even.
paulsstuff is offline  
post #5 of 5 (permalink) Old Dec 22nd, 12, 05:25 PM Thread Starter
Gold Lifetime Member
Steven
 
stamatisg1977's Avatar
 
Join Date: Sep 2005
Location: Mastic Beach Village, NY
Posts: 2,983
I get 44 at idle. I think the 80 was just a glitch in my scanner. But while driving under load it never goes up past 44psi. But just now I gunned it and there were no symptoms/problems

69 Frost Green Camaro
LS3 with TSP stage 3 cam
Tremec TKO 600
Moser 12 bolt rear with ford ends 3.73:1 Eaton tru trac differential
Speedtech pro touring subframe
Ridetech rear 4-Link


Follow my journey here:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
stamatisg1977 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome