Oil Low ?? - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Feb 16th, 07, 07:42 AM Thread Starter
patrick
 
Join Date: Feb 2007
Location: NC
Posts: 1
Oil Low ??

all right heres the deal i have a 1996 camaro nice car runs ok just had a head gasket replaced and here starts my woes drove the car out the shop ok running great but notice a slight thump under what appears to be the center console .. ok stop the car put in park rev the engine high and low then high not a dang sound its perfect ..so i put in drive hit the gas bang sund again like someone below my car hitting with a hammer get up to cruise speed no more strain on the engine and quiet as a mouse hit the gas theres that sound again seems only when i hit the gas or start from a stop only when there is load on the engine ok now problem 2 .. oil light when they did the head job the oil pressure switch broke put a brand new one in every time i start the car its a pot luck event if the low oil light is gonna come on sometimes it does (wel most of the time) and others it doesnt . checked the oil and its perfect on the money .. ok now my last and final problem so far .. transmission which may be related to problem 1 when the car is running there is a drip drip drip from the tranny nice red fluid car sits and not running no puddle .. debating on whether its a return hose but the tranny level is perfect low when cold and perfect when heated up . im thinking maybe tranny bolts got loosened a little its moving causing a banging and shifting the dipstick causing it to come out of the seal and leak a bit ? crazy .. not sure but dont have a lift so no way to tell for sure,.. any help would be appriciated .. (i love my car my first car was a 1980 camaro and finally after all these yrs of junkers got another camaro dont wanna lose it since now the engine is running like a dream .. oh yea one more thing slight what i can only describe as a air vaccum sounding leak or something slight whistle but not really coming from engine .. not sure maybe manifold gasket leaking or not tight not sure .. if i get the chance will link a video and audio file of it running ..
shaggycamaro is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Feb 16th, 07, 09:20 AM
Gold Lifetime Member
Harry
 
dawg's Avatar
 
Join Date: Mar 2004
Location: Colebrook CT.
Posts: 4,017
Re: Oil Low ??

first problem sounds like a transmission mount
also if not fixed will cause stress on tailshaft causing a leak.
oil pressure problem could be a bad switch of might be a bad or wrong head gasket. or pump i going. or the repair shop didnt replace the distributor O ring on the distributor shaft can cause pressure drop I think.
the whistling is probly a intake vacum leak.
I would question the workmanship of the repair shop that replaced the heads!
if you payed for them to repair I would get them to fix it right.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

434 stroker
US Navy retired

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dawg is online now  
post #3 of 5 (permalink) Old Feb 16th, 07, 01:30 PM
Gold Lifetime Member
Harley
 
wiskeesour's Avatar
 
Join Date: Nov 2006
Location: A van. Down by the river.
Posts: 6,359
Send a message via Yahoo to wiskeesour
Re: Oil Low ??

1)transmission mount.
2) Oil switch incorrect?
3)trans mount messedup tranny rear seal.

AE2(AW) Harley Moody, USNavy
"Master-at-Arms" for the CDWJB!!
November 26th, 2008 was my last day to serve my country as a member of the World's Greatest Navy.
Thanks Chief.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wiskeesour is offline  
 
post #4 of 5 (permalink) Old Feb 16th, 07, 03:30 PM
Moderator
____
 
DOUG G's Avatar
 
Join Date: Mar 1999
Location: Maryland, USA
Posts: 19,274
Garage
Send a message via MSN to DOUG G
Re: Oil Low ??

They warranty their work ?
*fix the vacuum leak (whistle)
*replace oil pressure switch

No thump before repairs ? someone "tested" her and broke mount, find another shop "one thats trustworthy"

68 Camaro~LSx ~all motor
1.54 60'--6.95 @ 98.45 660'--10.96 @ 121.53
DOUG G is offline  
post #5 of 5 (permalink) Old Feb 16th, 07, 05:34 PM
Senior Tech
bill
 
Join Date: Jan 2007
Location: new jersey
Posts: 601
Re: Oil Low ??

that thunk is your trans mount they go bad all the time in 82 and up camaros and firebirds with the tube that goes from trans to rear. when you step on gas rear raises and lifts up on trans mount.
jaguareats is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil Change Procedures for Women emperor91108 Bench Racing 9 Apr 8th, 12 10:10 AM
Funny but true oil change differences men/women b-boy Bench Racing 7 Jul 11th, 06 12:23 AM
Oil Change MRCOOL_RSSS350 Bench Racing 1 Apr 16th, 06 06:48 PM
New Engine, Low Oil Pressure? Cameron Engine 2 Sep 17th, 05 07:57 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome