Front blinkers not working - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old Feb 26th, 07, 01:13 PM Thread Starter
Ryan
 
Join Date: Feb 2007
Location: Austin, TX
Posts: 2
Front blinkers not working

'99 Camaro
My front blinkers don't work and when I use my turn signal, the rear turn lights stay solid. When I turn on my flashers, the rear turn lights blink as they should. From what I can tell, the front turn lights are not burnt out. Any ideas on how I can fix the problem? My inspection sticker expires in April and I need to get this fixed.

Thanks for any advice,
Ryan
rhyno13 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old Feb 26th, 07, 01:37 PM
Gold Lifetime Member
Kevin
 
SixtyAte's Avatar
 
Join Date: May 2005
Location: S. Eastern Massachusetts
Posts: 5,536
Re: Front blinkers not working

Try changing the directional flasher. The hazard flasher is fine based upon your post. Do the front lights flash also or only rears with the hazards on? If that is the case, try new bulbs after changing the flasher.

Kev
SixtyAte is offline  
post #3 of 8 (permalink) Old Feb 26th, 07, 04:15 PM
Senior Tech
Tony
 
Join Date: Jun 2005
Location: Long Island
Posts: 565
Re: Front blinkers not working

Check to see if they are making a good ground.
tonycamaro is offline  
 
post #4 of 8 (permalink) Old Feb 26th, 07, 07:48 PM
Senior Tech
 
Join Date: May 2001
Location: Ashby,MN, USA
Posts: 8,305
Re: Front blinkers not working

are the bulbs good?
how about the grounds?
corrosion in the sockets?
flashers could be bad.

you don't plan sincerity.
you have to make it up on the spot.

wanna hear about 20 years ago when i was too smart to know any better?
novaderrik is offline  
post #5 of 8 (permalink) Old Feb 26th, 07, 07:53 PM
Senior Tech
bruce
 
Join Date: Mar 2006
Location: apple valley,mn
Posts: 295
Re: Front blinkers not working

I agree with kevin, derectional flasher.
egore is offline  
post #6 of 8 (permalink) Old Feb 27th, 07, 02:37 PM Thread Starter
Ryan
 
Join Date: Feb 2007
Location: Austin, TX
Posts: 2
Re: Front blinkers not working

Quote:
Originally Posted by SixtyAte View Post
Try changing the directional flasher. The hazard flasher is fine based upon your post. Do the front lights flash also or only rears with the hazards on? If that is the case, try new bulbs after changing the flasher.

Kev

The front lights don't flash when the hazards are on. I'll try changing the directional flasher. Should I be able to pick that up at any auto parts store?

I really appreciate everyone's help.

Best regards,
Ryan
rhyno13 is offline  
post #7 of 8 (permalink) Old Feb 28th, 07, 03:31 PM
Gold Lifetime Member
Kevin
 
SixtyAte's Avatar
 
Join Date: May 2005
Location: S. Eastern Massachusetts
Posts: 5,536
Re: Front blinkers not working

Ryan...
Yes,
Any auto parts store will have the flasher..

Kev
SixtyAte is offline  
post #8 of 8 (permalink) Old Feb 28th, 07, 09:48 PM
Senior Tech
Alex Folino
 
Join Date: Aug 2005
Location: Pittsburgh Pennsylvania
Posts: 1,295
Send a message via AIM to AlexFolino
Re: Front blinkers not working

Flasher more than likely, working at Advance Autoparts i see this alot.

GM service technician.

25 years old. I only drive chevys. Everything else and i do mean everything can rust in piece.

68 owner-The only way to go
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Camaro: A small vicious animal that eats mustangs.
AlexFolino is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
cowl hood adjustment 68C Body Shop 16 Jan 30th, 14 07:08 AM
Front end decisions cushjbc Brakes, Suspension & Steering 0 Jan 8th, 06 10:57 PM
Front Seat Installation Unreal Interiors 0 Sep 20th, 03 01:07 AM
front blinkers wont work zac braaksma Electrical & Wiring 1 Jan 20th, 01 04:15 AM
No Front Turn signals? JC69RSZ28 Troubleshooting 1 Nov 13th, 00 01:51 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome