87 iroc w/mass air sensor problems? - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old May 25th, 09, 11:57 AM Thread Starter
 
Join Date: Jun 2008
Posts: 6
Unhappy 87 iroc w/mass air sensor problems?

i have an 87 iroc with a 350 tpi. it all of the sudden started running rough and stalling out on me. It eventually wouldn't even start. It spit code 33 (mass air) so i replaced the mass air, and it still did nothing. I can unplug the mass air, and it will start right up, eventually stalling out.. When you start it (with the mass air unplugged) , you can plug the mass air back in, turn the car off, and start it right up like nothing is wrong. You turn the car off n wait 5 or 10 minutes, and it won't start again. Same with the MAF sensor. You can unplug it, and it starts, you plug it back in and turn the car off for a minute and it won't start back up. I am hoping it's not the ECM since code 33 does mention that it might be defective. I don't want to take it to a mechanic because they will just jerk me around. My stepdad is the one who built this car, and he is just clueless when it comes to this. We have read the camaro book up and down, and still can't figure this out. This car only has 65k original miles on it. I really think its worth the hassle to fix it, I just can't seem to figure this out on my own. Any help would be greatly appreciated! Thanks in advance.
ftballmastr49 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old May 25th, 09, 01:45 PM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 32,014
Garage
Re: 87 iroc w/mass air sensor problems?

I would say to clean the MAF sensor using a sensor cleaner and make sure there are no holes/leaks in the bellows between the throttle body and MAF sensor.

Might even remove the IAC and clean its passage it sits in.

Of course, you've looked for other intake leaks?
Fuel pressure regulator hose is dry on the inside when you pull it off?

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden enjoy your next chapter.
Everett#2390 is offline  
post #3 of 6 (permalink) Old May 25th, 09, 03:14 PM Thread Starter
 
Join Date: Jun 2008
Posts: 6
Re: 87 iroc w/mass air sensor problems?

I did everything you said, and it still doesn't want to start. only if i unplug the mass air. There are no leaks what so ever, and the problem is still there.... anymore suggestions??
ftballmastr49 is offline  
 
post #4 of 6 (permalink) Old May 25th, 09, 06:16 PM
Senior Tech
 
Join Date: Mar 2002
Location: Austin, TX, USA
Posts: 5,277
Re: 87 iroc w/mass air sensor problems?

Here is one my prior posts on MAF problems that may help.
Quote:
Check the connector pins on the MAF. A friend of mine had one where the socket pins were spread open and enough corrosion (more like a dull film) developed to create a bad connection. It took him 3 MAF units (luckily the autoparts store accepted them for return) before we looked at those pins. We buffed the connector pins with a tiny bit of sandpaper, tightened them up with a pick probe and doped them with dielectric grease. The way we found the problem was by back-probing the MAF signal line and saw it was stuck on 5 volts.

Dave
========================
68 Coupe, 350 w/ Edelbrock Performer RPM heads, cam, intake, 700R4, Dave's small body HEI
dnult is offline  
post #5 of 6 (permalink) Old May 26th, 09, 12:18 PM
Senior Tech
Steiner
 
Join Date: Mar 2009
Location: Lyman, SC
Posts: 8,348
Re: 87 iroc w/mass air sensor problems?

I had the same contact problem on my S10 coil.

You can buy a used ECM on ebay for $50. I've got one for my truck that I sent off to have tuned and keep my original for a spare.

'69 Camaro
Dart 400-AFR 195-224/224 HR-Powerjection III TB with F.A.S.T. Sportsman XFI
TKO 600-Moser 3.42-Detroit Truetrac
500hp/538lbft

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'69 Camaro Beater-SFT 327-M20-Moser 4.10-sold
'02 Z/28 vert-stock-sold and totaled
Steiner is offline  
post #6 of 6 (permalink) Old May 28th, 09, 09:09 AM Thread Starter
 
Join Date: Jun 2008
Posts: 6
Re: 87 iroc w/mass air sensor problems?

thank you all for all of your advice, i really appreciate it. i still can't seem to figure this out. Looks like mechanic here i come... I found this "corvette dr." and 87 corvettes basically have the same tpi setup i guess?
ftballmastr49 is offline  
Sponsored Links
Advertisement
 
Reply

Tags
350, iroc z28, mass air sensor, stalling at idle, starting

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome