GM mechanic anyone; 94 3.1L idle probelm - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old May 31st, 09, 01:29 PM Thread Starter
Senior Tech
 
Join Date: Oct 2002
Location: Tracy\'s Landing, Md.
Posts: 499
GM mechanic anyone; 94 3.1L idle probelm

Not a Camaro , but still a Chevy!! I have a 94 Lumina with a 3.1 liter. This probelm started soon after a battery failure left the car dead on the road.( not sure if there is any coonection ) Anyway, cold starts are fine, but a re-start after the car has been thoroughly warmed up and had a chance to cool for a bit idle races up to about 2K and slowly drops down to normal. The car doesn't have any codes stored , in fact the only code I've seen in the 240K we've owned is was an EGR 32. I will say , within the last couple months my daughter has said the SES light has come on but goes off and it has been the EGR valve. Any thoughts woudl be appreciated, I'd hate to give in and put her in the shop ...again. I don't want to knee jerk and replace the EGR at $180 but if I knew without a doubt then i'd do it.

69 coupe 383 Dart,Scat,SRP...,M21, 411 12 bolt
69 ZII 350, auto,373 12 bolt
2017 Chevy SS sedan LS3
69pace is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Jun 1st, 09, 03:39 AM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,620
Garage
Re: GM mechanic anyone; 94 3.1L idle probelm

You might remove and check the EGR valve by pouring gas in one port and look for it to not leak into the other port.

Plus the other stuff going along with it - check diaphram for no holes, frame of valve in good repair, not rusted.

Let's see if I remember, short ALDL pins A & B together, turn ign to on, ECM commands EGR solenoid to open allowing vacuum to open valve - get a long hose and check operation. Hoses/tubing in good shape?

O2 sensor ever been changed?

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - maybe this year, 2019 ...
Everett#2390 is offline  
post #3 of 3 (permalink) Old Jun 1st, 09, 03:04 PM
Senior Tech
David
 
Join Date: May 1999
Location: Jefferson City, MO.
Posts: 621
Re: GM mechanic anyone; 94 3.1L idle probelm

the problem is the Idle Air Control Valve has lost it's "memory" for the idle speed when the battery went bad. Sometimes they will correct themselves, but it can take a good deal of driving. otherwise it needs to be put on the computer and "relearned". Seen this many times when the battery is disconnected for any reason. This was a "normal" condition on those cars when the battery is disconnected.

67 RS marina blue, 406 ,M20 4spd, 9". car has been in my family since new!

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
67FREAK is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome