March power stearing pump??? - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Jun 1st, 09, 06:02 PM Thread Starter
Gold Lifetime Member
Dave C
 
Join Date: Jan 2007
Location: maryland
Posts: 5,495
Send a message via AIM to Pro-Street69Camaro468 Send a message via Yahoo to Pro-Street69Camaro468
March power stearing pump???

I have a March serpintine set up and am having problems when I drive and the car heats up the stearing gets hard.Has anyone experienced this.The pump is a 87 sunbird and the rack is a 87 thunderbird and the pressures need to match has any one had any experience with this. Thanks in advance.

PRO.ST69orange

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Pro-Street69Camaro468 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Jun 4th, 09, 06:09 PM Thread Starter
Gold Lifetime Member
Dave C
 
Join Date: Jan 2007
Location: maryland
Posts: 5,495
Send a message via AIM to Pro-Street69Camaro468 Send a message via Yahoo to Pro-Street69Camaro468
Re: March power stearing pump???

I found the problem this week and it is fixed now. I bought a pressure reducing kit and it required two washers I thought I only put one but there were two.When I took it apart the check valve was sticking iI cleaned it put three washers on it and it was fine but not real easy to steer so I went back with two washers.I think it may have just been rubber from the an hose cuts I made.This is if anyone ever has this problem....

PRO.ST69orange

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Pro-Street69Camaro468 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome