engine fails in corners - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old Jul 3rd, 09, 01:50 AM Thread Starter
 
Join Date: Jun 2009
Location: Belgium
Posts: 17
engine fails in corners

Hi everyone,

If I drive around in my '67 camaro everything is fine but if I take a u turn or a fast corner, my engine wants to shut down. And it is hard to start again after it shuts down. I think maybe there is something wrong with the fuel lines? I have a holley electric fuel pump, so normally this would be ok?

best regards, Joeri (Belgium)
joeri is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old Jul 3rd, 09, 03:41 AM
Gold Lifetime Member
Harry
 
dawg's Avatar
 
Join Date: Mar 2004
Location: Colebrook CT.
Posts: 4,020
Re: engine fails in corners

float level too low in the carb?????


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

434 stroker
US Navy retired

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dawg is offline  
post #3 of 8 (permalink) Old Jul 3rd, 09, 08:39 AM
Senior Tech
john
 
wagonman's Avatar
 
Join Date: Oct 2004
Location: northern california
Posts: 2,796
Re: engine fails in corners

I would expect to see the same thing.......low fuel level.......way low.....

Remember,I'm not making this stuff up!

1969 rs/ss 396 350hp/4spd conv a/c,pw,ps,foldown
1968 Z/28 crossram- j/l8 conv pw,ps,foldown
1963 nova ss 350/4spd conv a/c,ps,pt
1963 nova 400 4dr 6cyl/700r4 a/c
2006 GT/5spd mustang conv
wagonman is offline  
 
post #4 of 8 (permalink) Old Jul 3rd, 09, 08:59 AM
Senior Tech
Timothy
 
Join Date: Sep 2007
Location: San Antonio TX
Posts: 1,804
Re: engine fails in corners

I had a car do this and it was the fuel filter. Cheap to change to I would try this first.

My 69 RS/SS 396 Project -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


"I may be dumb but I aint stupid"
Microgiant is offline  
post #5 of 8 (permalink) Old Jul 3rd, 09, 09:05 AM
 
Join Date: Jun 2009
Posts: 10
Re: engine fails in corners

i had a similar things and after it died it would take a while to start until one day it didnt start at all. i had it towed to a repair shop and they said it was the ignition module. they replaced it and it was solved.
4THECHALLENGE is offline  
post #6 of 8 (permalink) Old Jul 3rd, 09, 09:44 AM
Senior Tech
 
Join Date: Apr 2008
Location: Illinois
Posts: 614
Re: engine fails in corners

Holley put the dual feed center hung float bowls on hi-po carbs because the side hung bowls would lower the fuel level when turning one way and raise the level turning the other way. What carb do you have? A high float level might spill fuel thru the vent tube and flood the motor during spirited driving. Hard starting from flooded motor?
markw is offline  
post #7 of 8 (permalink) Old Jul 5th, 09, 07:48 AM Thread Starter
 
Join Date: Jun 2009
Location: Belgium
Posts: 17
Re: engine fails in corners

I will change the fuel filter and see if the problem remains...

thanks for the response everyone!

best regards, Joeri
joeri is offline  
post #8 of 8 (permalink) Old Jul 7th, 09, 11:20 PM
Senior Tech
Ron
 
Join Date: Nov 2006
Location: North Channel Lake Huron
Posts: 3,934
Re: engine fails in corners

On a long drive home in my 69 123S Volvo, 20 below in a snow storm, every time I took a right corner the engine would cut out and about quit. Finally I had to pull over and discovered the distributer was loose. I can only imagine that the centrifugal force of a right corner weighted the plug wires just enough to turn the distributer, yet it would return to the proper position while travelling in a straight line or through a left turn - LOL

Z15CAM - There was a Viper in my Rear View
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

This was my 70 1/2 Z28

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Z15CAM is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome