M/C solenoid......? - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old Jul 14th, 09, 05:34 PM Thread Starter
Thomas
 
Join Date: Jul 2008
Location: California
Posts: 19
Exclamation M/C solenoid......?

alright heres the deal my 89 305 rs starts up but wont stay idle it dies out an i've looked at kragen, autozone for a new M/C solenoid but no luck should pocket for new carb or hit up pick n pull/ car junk yards......?
Thomas707 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old Jul 14th, 09, 06:37 PM
Moderator
Bill
 
Join Date: Aug 1998
Location: Waldorf Md. USA
Posts: 3,280
Re: M/C solenoid......?

Thomas,
I got one for my Wife's 84 Riviera at the dealer about a year ago. Have you tried the Chevy dealer ? Also, are you sure that is the problem ? It really should idle even with the MC solonoid not working. Can you hear it "clicking" when you turn the key on ?

You really need to put a scanner on it and see what the MC dwell is before you start changing things. Also, there is a small set of special tools you need to adjust the new solonoid when you replace it, without the tools and a scanner, its pretty hard to do anything with the electronic Q-jets.

By the way, if it was running ok till just recently, I would stay away from the reman carbs and try to fix yours. I have heard a lot of horror stories about them being worse than the old one that was taken off If nothing else, make sure to save your old carb until you are absolutely sure that the new one works properly.

Bill Koustenis
Owner
Advanced Automotive Machine
Waldorf Md
1971 Chevelle "Heavy Chevy" original owner


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
BillK is offline  
post #3 of 7 (permalink) Old Jul 15th, 09, 03:18 PM
Tech Team
 
Join Date: Jun 2006
Location: chicago burbs
Posts: 31
Re: M/C solenoid......?

not sure if i missed something, but an '89 305 rs is fuel injected and as such does not have an m/c solenoid.
chevrolover is offline  
 
post #4 of 7 (permalink) Old Jul 15th, 09, 04:59 PM
Senior Tech
 
Join Date: Mar 2002
Location: Austin, TX, USA
Posts: 5,277
Re: M/C solenoid......?

Quote:
Originally Posted by chevrolover View Post
not sure if i missed something, but an '89 305 rs is fuel injected and as such does not have an m/c solenoid.
That must be it!

Dave
========================
68 Coupe, 350 w/ Edelbrock Performer RPM heads, cam, intake, 700R4, Dave's small body HEI
dnult is offline  
post #5 of 7 (permalink) Old Jul 16th, 09, 01:12 AM Thread Starter
Thomas
 
Join Date: Jul 2008
Location: California
Posts: 19
Re: M/C solenoid......?

well i have the scanner an it gave me 2 flashes pause then three i have the for from autozone an itsaid to check the wiring connections i did its seems fine and i had my dad come take a look he said it was drowning itself...its starts, idels, then turns off. mine is t.hrottle b.ody i.njected
Thomas707 is offline  
post #6 of 7 (permalink) Old Jul 17th, 09, 09:55 PM
Senior Tech
 
Join Date: May 2001
Location: Ashby,MN, USA
Posts: 8,305
Re: M/C solenoid......?

check all the sensor wiring.
a temp sender that is shorting out will cause all sorts of weird problems. if it runs good when cold but then starts running progressively worse as it warms up, then i'd check to make sure that the temp sender wires aren't shorting together.
O2 sensor will also cause it to act all wonky after it warms up.
check the hose to the MAP sensor- a bad vacuum reading will cause the computer to freak out.
check that the TPS voltage is good at idle, and that it kicks out a smooth signal as you open the throttle.
and finally- check for vacuum leaks. grab a 13mm socket and snug down the throttle body bolts, and make sure the hoses to the PCV valve and brake booster are in good shape.
this is all basic stuff that costs nothing and only takes a little time to check.

you don't plan sincerity.
you have to make it up on the spot.

wanna hear about 20 years ago when i was too smart to know any better?
novaderrik is offline  
post #7 of 7 (permalink) Old Jul 20th, 09, 04:25 PM Thread Starter
Thomas
 
Join Date: Jul 2008
Location: California
Posts: 19
Question Re: M/C solenoid......?

good **** well the trouble code im positive now means the (mat) sensor manifold air temp so how does this work.....?
Thomas707 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome