Help! Huge loss of Torque and Acceleration. - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Jul 31st, 09, 06:54 PM Thread Starter
 
Join Date: Jul 2009
Posts: 7
Help! Huge loss of Torque and Acceleration.

I am a proud owner of A 1990 Camaro Rs 305 V8 5.0L. I have done some research and i believe it is going into Limp Home mode, but the car will run great for a while then as soon as the Service Engine Light comes on there is a huge loss in torque and acceleration. If i turn the car off and back on the service engine light is off and car runs fine. Just changed oil and air filters and the oil. Any Help? I plan on taking it to autozone to have them read the code, but who knows if the service engine light will be on then..
mtmajeski is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Aug 1st, 09, 06:28 AM
Senior Tech
Dan Ensign
 
Join Date: Jan 2007
Location: Claverack,NY
Posts: 366
Re: Help! Huge loss of Torque and Acceleration.

A code will be stored in the ecm regardless of wether or not the light is on. You can also get the code from that car by jumping the diagnostic plug with a paper clip. If i remember correctly you jump the two plugs in the upper right corner of the diag. connector. Witht the key on engine off the check engine light will flash, ther will be short flashes and long flashes. it will flash code 12 4 times then your trouble code 3 times for each code then a code 12 again when all codes have been flashed. Let us know how you make out.

Dan E.
69 SS396 4spd. 4.11 posi. x66 coupe
Dan E. is offline  
post #3 of 3 (permalink) Old Aug 1st, 09, 09:28 AM Thread Starter
 
Join Date: Jul 2009
Posts: 7
Re: Help! Huge loss of Torque and Acceleration.

Alright thanks I really appreciate it, i'm taking it in right now I'll let you know how it turns out.
mtmajeski is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome