89 Camaro RS starting/fuel problem - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Aug 28th, 09, 05:13 PM Thread Starter
 
Join Date: Aug 2009
Posts: 2
89 Camaro RS starting/fuel problem

i have an 89 camaro v8 that died the other day, replaced the starter and at first didnt start, but then started on the second try. although it sounds like something is maybe grinding when it starts up. also when its driving its really hesitant and when idling shuts off at times, now this was happening before the starter issues. fuel filter, plugs, wires, alt, starter have all been replaced with the fuel problem still happening. any ideas on what is or maybe going on?
local is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Aug 30th, 09, 05:40 AM Thread Starter
 
Join Date: Aug 2009
Posts: 2
Re: 89 Camaro RS starting/fuel problem

i guess nobody has an idea on whats going on?
local is offline  
post #3 of 3 (permalink) Old Aug 30th, 09, 09:16 AM
Senior Tech
 
Join Date: Mar 2002
Location: Austin, TX, USA
Posts: 5,277
Re: 89 Camaro RS starting/fuel problem

Sounds like the IAC motor may not be controlling the idle speed correctly. Vacuum leaks can also cause it. Some of those cars had a MAF that was connected by plastic duct work to the throttle body. If the duct work developed a crack or wasn't sealed up well, a vacuum leak developed that would cause drivability issues.

First step would be to determine if there are any codes set and record what they are. Be sure to get code numbers and not verbal descriptions of the codes. You may be able to get a free code read from your local autozone. If you're a techie, there is a way you can get codes out of that ECM yourself. Are you familiar with how that's done?

Whatever you do, don't start swapping parts until you have a better idea what the problem is / isn't.

Dave
========================
68 Coupe, 350 w/ Edelbrock Performer RPM heads, cam, intake, 700R4, Dave's small body HEI
dnult is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome