85 tpi - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Sep 11th, 09, 08:49 AM Thread Starter
 
Join Date: Sep 2009
Posts: 2
Angry 85 tpi

I have these 85 vette (tpi)and just off idle It boggs and then pops, If I hold it just off of idle It will pop until it dies. If I floor it, It will hasatate and then RPM's fly high. This problem started with a surge while driving, followed with black smoke. the smoke went a way then ran rich.I put new plugs in it and seemed to help alot .NEED HELP
mikefaster is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Sep 11th, 09, 07:26 PM
Senior Tech
Scott
 
Join Date: Jun 2006
Location: Pensacola, FL
Posts: 581
Garage
Re: 85 tpi

Possibly MAP sensor? Is the service light on? Injector gone bad & bleeding down? Hard to say without a little more info.
Scott

69 RS LS3/T56
68 Firebird vert LS1/4L60E
67 RS LS2/T56
Z06vette is offline  
post #3 of 3 (permalink) Old Sep 12th, 09, 10:27 AM Thread Starter
 
Join Date: Sep 2009
Posts: 2
Re: 85 tpi

Quote:
Originally Posted by Z06vette View Post
Possibly MAP sensor? Is the service light on? Injector gone bad & bleeding down? Hard to say without a little more info.
Scott
No engine light and no codes,Im lost It has to be fuel related,Fuel preasure is great time is good, power is great after the stumble off idle.runs rich seems to be fowling out the plugs
mikefaster is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome