69 z28 dz 302 windage tray trouble. - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Oct 10th, 09, 01:48 AM Thread Starter
dave
 
Join Date: Jun 2008
Location: ohio
Posts: 19
69 z28 dz 302 windage tray trouble.

I AM ASSEMBLING MY 69 DZ 302 AND HAVE A FEW QUESTIONS I CAN'T
FIND THE ANSWERS TO.WHAT IS THE TORQUE ON THE WINDAGE TRAY NUTS? DOES THE RAILS ON THE SIDES OF THE OIL PAN GO BESIDE THE WINDAGE TRAY OR SET ON THE TRAY.

THANKS,DAVE
BIGRAT is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Oct 28th, 09, 01:08 PM
Senior Tech
Rich
 
Join Date: May 2005
Location: DFW Texas
Posts: 1,639
Re: 69 z28 dz 302 windage tray trouble.

IIRC they are 3/8 threads so about 35 ft-lb should be fine- may add threadlocker too

69 R/S Z/28 302 X33 D80 late 09C
69 T/A clonification LS6-6speed under construction
15 ZL1
64 Chevelle wagon 6.0l planned sons toy
zman1969 is offline  
post #3 of 3 (permalink) Old Oct 31st, 09, 09:42 AM
Senior Tech
Ron
 
Join Date: Nov 2006
Location: North Channel Lake Huron
Posts: 3,934
Re: 69 z28 dz 302 windage tray trouble.

I've a 68 010 4 Bolt Block with 67 Grumpy Spec'd 281 Heads. I used the OEM Vette Windage-Tray and 4 Qt Pan that Bolts to the outer Studs of the 4 Bolt Main Bolt - which basically was the man reason I choose the 4 Bolt and probably the same Tray & Pan used for the DZ 302. I run the large Journal Forged 3.25" Stoke 68 327 Crank and forged TRW-L2166NF30 pistons to give me an 11:1 Static Compression. I choose the Sigerson F-296-1 SFT Cam which gives me an 8.2:1 Dynamic Compression - She's a 8000+rpm motor and has been shelved until I tire of my 625Hp 7000rpm LS4 - One of these days, I want to get back into a LT1 SBC with a M21 & 3.55 Gears.

Z15CAM - There was a Viper in my Rear View
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

This was my 70 1/2 Z28

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Z15CAM is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome