Sensor making me run rich? - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Jan 12th, 10, 03:54 PM Thread Starter
 
Join Date: Jan 2010
Posts: 1
Sensor making me run rich?

I gotta 1991 Camaro RS with a 3.1 V6. At a cold startup, the engine runs like its got a miss. My Autoxray says the car is running rich and I can't diagnose it at all. For some reason, my ECM wants to keep purging the vapor canister ALL the time. Cold or hot and in any driving condition, the ecm never commands the purging to quit. I'm thinking the ecm is getting a signal from a sensor telling the ecm that it needs to turn on the purge solenoid. I don't know what the ecm relies on to turn the solenoid on or off. I have a good idea that it might be the Coolant Temp sensor. My BLM and Integrator are at 100 and I'm getting horrible gas mileage. The integrator can be on 128 at idle then slowly go down to 85 then idles really crappy and all of a sudden the ecm will compensate to knock it up to 128 again only to start dropping below 100. I don't want to throw parts at it hoping to correct it. Any suggesstions? I have had this car for 15 years and wouldn't trade it for nothing.

Ken
ken3983 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Jan 12th, 10, 04:17 PM
Gold Lifetime Member
John
 
Vintage 68's Avatar
 
Join Date: Mar 2002
Location: Moraga,Ca.,USA
Posts: 13,705
Thumbs up Re: Sensor making me run rich?

Like you said - the CTS is probably the culprit
It will maintain the Purge if it doesn't sense the engine is up to temp.
Causes the fuel map to stay rich also.
Test and replace it and see if the issue(s) doesn't go away.
They will not set a code when bad -
I just replaced one a few months ago to fix a stumble problem ... go fiqure.

1968 Convertible
Some trucks
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Other V8 things - some of which float
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Other V6 things - none of which float
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Oh yeah, and 1 "Straight-Six" ...
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


If a man says something in the garage - and his wife can't hear him - is he still wrong !!!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Vintage 68 is offline  
post #3 of 3 (permalink) Old Jan 12th, 10, 05:48 PM
Senior Tech
Steiner
 
Join Date: Mar 2009
Location: Lyman, SC
Posts: 8,348
Re: Sensor making me run rich?

I agree. See what your program says your coolant temp is. It will stay in open loop and run rich if it doesn't get above 150 degrees or so.

'69 Camaro
Dart 400-AFR 195-224/224 HR-Powerjection III TB with F.A.S.T. Sportsman XFI
TKO 600-Moser 3.42-Detroit Truetrac
500hp/538lbft

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'69 Camaro Beater-SFT 327-M20-Moser 4.10-sold
'02 Z/28 vert-stock-sold and totaled
Steiner is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome