Keeps running - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Mar 21st, 10, 10:30 AM Thread Starter
Tech Team
 
Join Date: Jun 2008
Location: Chicago
Posts: 55
Keeps running

79 350 motor auto trans Camaro. MSD dis and box box keeps running when I turn the key off,only sometime.to get the car to turn off turn the key on give it gas turn the key off than it would shut off only does it some times.Why is it doing this?
Rebel72 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Mar 21st, 10, 12:53 PM
Senior Tech
Ron
 
Join Date: Nov 2006
Location: North Channel Lake Huron
Posts: 3,934
Re: Keeps runiing

I don't know if you are describing Diesel Run-On or you saying the Coil is not De-Energizing when the Key is turned off.

Dieseling is caused by improper Carb Throttle Plate Position (Vacuum Leak Issues) and Timing; where as, a Live Coil after Key Turn of means you NOT killing power to the Coil which can be caused by Improper Wiring or possible that the Alternator is activating the Ignition Circuit upon shut down in which case you may have to put an Condenser from Alternator Out Put to Ground.

Z15CAM - There was a Viper in my Rear View
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

This was my 70 1/2 Z28

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Z15CAM; Mar 21st, 10 at 01:05 PM.
Z15CAM is offline  
post #3 of 4 (permalink) Old Mar 21st, 10, 01:29 PM
Senior Tech
 
Join Date: Mar 2002
Location: Austin, TX, USA
Posts: 5,277
Re: Keeps runiing

You might search for the keyword diode. I know MSD setups can suffer from a problem where they remain energized enough to back-feed the electical system. Installing a diode was a work around. You should also find info on the MSD website about it.

Don't overlook the possibility of a bad ignition switch or another wiring problem.

Dave
========================
68 Coupe, 350 w/ Edelbrock Performer RPM heads, cam, intake, 700R4, Dave's small body HEI
dnult is offline  
 
post #4 of 4 (permalink) Old Mar 21st, 10, 02:25 PM
Senior Tech
Ron
 
Join Date: Nov 2006
Location: North Channel Lake Huron
Posts: 3,934
Re: Keeps runiing

Quote:
Condenser
Should have said DIODE

Also a bad Diode in the Alternator's Rectifier Circuit can cause the Alternator to continue charging after the Key is turned off.

X's 2 on Faulty Ignition Switch.

Z15CAM - There was a Viper in my Rear View
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

This was my 70 1/2 Z28

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Z15CAM is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome