Vehicle Shutting Off - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old Mar 30th, 10, 06:12 PM Thread Starter
brian
 
Join Date: Mar 2010
Location: north carolina
Posts: 1
Vehicle Shutting Off

95 Camaro 3.8L MT
My Camaro has a few problems with it, but the worst is the way it will just shut off when I slow down. It started a few weeks ago but tonight it cut off twice within 10 minutes of driving, it used to happen maybe once a week. It also stutters when Im accelerating sometimes and sometimes it jerks really hard. Another problem is the cooling fans are not coming on allowing the car to get hot while Im waiting in a drive thru or where ever. Ive checked all the relays and theyre fine, the fans run properly when I jump the connections, I usually turn my ac on then off and the fans will stay on at low speed until I shut the car off. Ive replaced the coolant temp sensor and it didnt help. Ive been reading in these forums how thats a pretty common problem but eventually I will find out why they dont work, Im mapping out all of my electrical connections and will test everything. I have a work around for the fans for now but I cant figure out why the thing keeps stuttering/dying. The check engine codes complain about O2 sensors (I dont have a catalytic converter) but recently a MAF/VAF low voltage input. Ive checked the voltage and resistance to the MAF and theyre good. I found a crack in a vacuum hose and fixed it a couple of days ago but it didnt get any better. Within the past month Ive replaced the air filter, fuel filter, oil, and oil filter along with the coolant temp sensor. Nothing has helped. Im going to change the spark plug wires and maybe the spark plugs next. Then if that dont help I will get another computer or borrow someones to test it. Any thoughts or ideas would be appreciated!
briandm03 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome