Holley Accel Pump? - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Apr 3rd, 10, 08:20 AM Thread Starter
Senior Tech
Gary
 
Join Date: Mar 2009
Location: Auburn, CA
Posts: 439
Holley Accel Pump?

What are the typical symptoms of a bad, or worn out accel pump? My Holley 670 still has a slight stumble of idle. The carb is about 3 yrs old. Thanks

Gary
Gar's67 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Apr 3rd, 10, 09:21 AM
Senior Tech
Steve
 
Join Date: Jun 2005
Location: central New York
Posts: 1,654
Re: Holley Accel Pump?

That is a typical symptom. I had the same thing, turned out to be two bad plug wires. Also had it once on a Corvette and it was a cracked porcelain on one spark plug.

1969 Z28

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Firebird 400

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

My new project for 2010 DONE/ Sold.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2002 Camaro SS LE/SLP
67 Nova SS 327, M20, 3.73
nashcar is online now  
post #3 of 3 (permalink) Old Apr 3rd, 10, 06:10 PM
Senior Tech
Alan
 
Join Date: Oct 2007
Location: SoCal
Posts: 3,905
Re: Holley Accel Pump?

If the electronics check out ok from the above suggestion, it could very well be that you need to play with the pump shot. You can get a kit from Holley that has several different cams so you can experiment. Make sure that the pump is adjusted so there is no lag in pump shot coming off the accelerator. In some cases, you might even need to change the nozzle size of the accelerator pump which is also easy to do. Just make sure the butterflies are closed when you change the nozzle. The nozzle is held in via a phillips head screw and watch for the gasket under the screw.

alan
alanrw is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome