2001 3.8 running rough - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Jun 25th, 10, 12:31 AM Thread Starter
chuck
 
Join Date: Jun 2010
Location: stinnett tx
Posts: 14
Send a message via Yahoo to newcareer
2001 3.8 running rough

car runs rough & surges at highway speeds,had scanned 2 times at auto zone ,dont remember exact code but came up egr valve.car ran excellent one day I washed motor nothing out of norm ,like to not made it home, had scanned ,read crankshaft sensor & egr valve ,started running fine again had scanned no codes, went to crap again had scanned read manufacturers secondary emission control failed looked up code read egr valve,hell I pulled it off checked it seemed fine to mecode said stuck open it wasnt pintle moves fine how do I check it cant afford 165 bucks if it aint bad,please help meoutonly car I got goin to welding school
newcareer is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Jun 25th, 10, 03:45 AM
Gold Lifetime Member
BILL
 
SPARKY69's Avatar
 
Join Date: Oct 2007
Location: HENDERSONVILLE N.C.
Posts: 9,352
Re: 2001 3.8 running rough

Pull off your egr valve and clean out the pintle with some carb/fi cleaner real good and make sure the pintle moves up and down before you put it back on..sometimes that will work ..they get full of carbon in there and clean out your throttle body also..

BILL D.
JOHN 3:16
SEMPER FI
if you have a bbc in your 1st gen 67-69 camaro click on the link below and enjoy the veiw and post yours up!!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

if you have an all original 1st gen camaro 67-69 click on the link below and enjoy the veiw and post your up!!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
SPARKY69 is offline  
post #3 of 5 (permalink) Old Jun 26th, 10, 07:50 PM Thread Starter
chuck
 
Join Date: Jun 2010
Location: stinnett tx
Posts: 14
Send a message via Yahoo to newcareer
Re: 2001 3.8 running rough

broke down & bought the high dollar f
newcareer is offline  
 
post #4 of 5 (permalink) Old Jun 26th, 10, 07:52 PM Thread Starter
chuck
 
Join Date: Jun 2010
Location: stinnett tx
Posts: 14
Send a message via Yahoo to newcareer
Re: 2001 3.8 running rough

It
newcareer is offline  
post #5 of 5 (permalink) Old Jun 26th, 10, 08:00 PM Thread Starter
chuck
 
Join Date: Jun 2010
Location: stinnett tx
Posts: 14
Send a message via Yahoo to newcareer
Re: 2001 3.8 running rough

Well it was the EGR valve ,damn thing was 189 bucks at auto zone borger tx store,according to the guy working there ajumper wire from center terminal to either outside terminal activates it one way or the other . mine didnt do diddly. running fine again ,thanks for the info but I already did that.Oh well its only money,in which case I AINT GOT!!!!!!!!!!!!!!!!!
newcareer is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome