Backfire Thru Carb From Running Great?? - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old Aug 18th, 10, 11:29 PM Thread Starter
Senior Tech
Steve
 
Join Date: Aug 2006
Location: Kula, Maui
Posts: 165
Backfire Thru Carb From Running Great??

HELP!! My 327 with MSD ignition was running great. Timing was right on. Today, leaving work, went a block and it started poping through the carb. Engine starts but wont idle or run without gas peddle and it just backfires through the carb.
I just had the MSD Ready To Run Pro Billit rebuilt by MSD with new gear, cap, rotor and PC Board, installed it a week ago with new coil. I checked NO 1 TDS and rotor alignment and it was good. Distributor hadn't moved. Anyone have a clue how to diagnose this? I will be eternally grateful!
Many thanks,
Steve
smiller is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old Aug 31st, 10, 12:39 PM
Senior Tech
Wes
 
Join Date: Dec 2003
Location: Leander, TX
Posts: 2,775
Re: Backfire Thru Carb From Running Great??

Possible solutions:

1) Firing order problem
2) Bad plug wires
3) Cracked distributor cap
4) Broken valve spring(s)
Straight-line-69 is offline  
post #3 of 8 (permalink) Old Aug 31st, 10, 12:51 PM
Senior Tech
Steps
 
Join Date: Dec 2005
Location: New Zealand
Posts: 13,321
Re: Backfire Thru Carb From Running Great??

Change the spark plugs

My Spelling is not incorrect...it is creative

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Steptoe is offline  
 
post #4 of 8 (permalink) Old Sep 1st, 10, 06:54 PM
Senior Tech
 
Join Date: Mar 2002
Location: Houston, Texas U.S.
Posts: 683
Re: Backfire Thru Carb From Running Great??

5. bent or broken push rod
6. wiped cam

EricE
68 Butternut Yellow
SS Coupe 396/325
stope4 is offline  
post #5 of 8 (permalink) Old Sep 2nd, 10, 06:10 AM
Senior Tech
Chuck
 
Join Date: Apr 2007
Location: Austin, TX
Posts: 926
Re: Backfire Thru Carb From Running Great??

If not igniton related, can also be caused by a lean condition. Accelerator pump not working, loss of fuel pressure to carb, float sticking.
Chuck is offline  
post #6 of 8 (permalink) Old Sep 2nd, 10, 10:55 AM
Gold Lifetime Member
Steve
 
Join Date: Nov 2007
Location: South Jersey
Posts: 1,441
Re: Backfire Thru Carb From Running Great??

You may want to pull the distributor to make sure there's no problem with the gear that engages the cam. It may have some bad teeth that changed the timing on you, although this would show up with a timing light. I always look at the last thing changed when troublshooting a new problem.

69 SS, 350/300 h.p., M-20, 12 bolt, matching numbers.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
reelknots is offline  
post #7 of 8 (permalink) Old Sep 2nd, 10, 01:41 PM
Senior Tech
Steps
 
Join Date: Dec 2005
Location: New Zealand
Posts: 13,321
Re: Backfire Thru Carb From Running Great??

The question was raise a fortnight ago, the guy hasnt been back since asking.

My Spelling is not incorrect...it is creative

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Steptoe is offline  
post #8 of 8 (permalink) Old Sep 2nd, 10, 08:18 PM
Gold Lifetime Member
Steve
 
Join Date: Nov 2007
Location: South Jersey
Posts: 1,441
Re: Backfire Thru Carb From Running Great??

Maybe he's still driving home!!!

69 SS, 350/300 h.p., M-20, 12 bolt, matching numbers.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
reelknots is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome