My pass side low beam keeps blowing... - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old Aug 19th, 10, 12:26 AM Thread Starter
Gold Lifetime Member
Harley
 
wiskeesour's Avatar
 
Join Date: Nov 2006
Location: A van. Down by the river.
Posts: 6,359
Send a message via Yahoo to wiskeesour
My pass side low beam keeps blowing...

Ive looked and searched and can not figure out why my low beam on the passenger side keeps blowing. It takes about 2 weeks after a new bulb and quits working. The high beam on the pass side still works but the low beam quits.
What could be causing this? Anyone have a guess?

As always help is greatly appreciated...

AE2(AW) Harley Moody, USNavy
"Master-at-Arms" for the CDWJB!!
November 26th, 2008 was my last day to serve my country as a member of the World's Greatest Navy.
Thanks Chief.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wiskeesour is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old Aug 19th, 10, 02:30 AM
Senior Tech
Steiner
 
Join Date: Mar 2009
Location: Lyman, SC
Posts: 8,348
Re: My pass side low beam keeps blowing...

I would guess poor connection in the terminal socket. You may be able to see signs of overheating on the connector and maybe you can push the terminals out to see if they need to be redone with solder.

On a side note, a great upgrade is a relay harness. You can get them for about thirty bucks on ebay although with the cheap ones the terminals are just crimped and need to be soldered. It's a pigtail that connects to the battery and then your original connectors plug in on one side and the other side plugs into your headlights. It'll put full battery voltage on the headlights instead of having to run through your headlight switch.

'69 Camaro
Dart 400-AFR 195-224/224 HR-Powerjection III TB with F.A.S.T. Sportsman XFI
TKO 600-Moser 3.42-Detroit Truetrac
500hp/538lbft

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'69 Camaro Beater-SFT 327-M20-Moser 4.10-sold
'02 Z/28 vert-stock-sold and totaled
Steiner is offline  
post #3 of 8 (permalink) Old Aug 19th, 10, 07:15 AM Thread Starter
Gold Lifetime Member
Harley
 
wiskeesour's Avatar
 
Join Date: Nov 2006
Location: A van. Down by the river.
Posts: 6,359
Send a message via Yahoo to wiskeesour
Re: My pass side low beam keeps blowing...

I searched for 68 camaro headlight relay harness to no avail.
Got a link? Appreciate the help Steiner...

AE2(AW) Harley Moody, USNavy
"Master-at-Arms" for the CDWJB!!
November 26th, 2008 was my last day to serve my country as a member of the World's Greatest Navy.
Thanks Chief.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wiskeesour is offline  
 
post #4 of 8 (permalink) Old Aug 19th, 10, 12:02 PM
Senior Tech
Dave
 
Join Date: Apr 2001
Location: Southern NH
Posts: 1,089
Re: My pass side low beam keeps blowing...

one other thing to look at is your voltage regulator output. mine was fine at idle but 16v at 3k and blew 3 drivers side headlights nbefore i figured it out.
Dave69Z is online now  
post #5 of 8 (permalink) Old Aug 19th, 10, 12:18 PM
Senior Tech
Michael
 
Join Date: Apr 2010
Location: Lutz, FL
Posts: 1,918
Re: My pass side low beam keeps blowing...

Or the headlight bucket isn't anchored with enough bolts and the vibration from driving is shaking the filament loose.
mahunt is offline  
post #6 of 8 (permalink) Old Aug 19th, 10, 06:00 PM
Senior Tech
Steiner
 
Join Date: Mar 2009
Location: Lyman, SC
Posts: 8,348
Re: My pass side low beam keeps blowing...

Quote:
Originally Posted by wiskeesour View Post
I searched for 68 camaro headlight relay harness to no avail.
Got a link? Appreciate the help Steiner...
This is the one I have. I got it so I could run high wattage lamps. It's not installed yet though.
http://cgi.ebay.com/ebaymotors/H4-90...ts_Accessories

'69 Camaro
Dart 400-AFR 195-224/224 HR-Powerjection III TB with F.A.S.T. Sportsman XFI
TKO 600-Moser 3.42-Detroit Truetrac
500hp/538lbft

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'69 Camaro Beater-SFT 327-M20-Moser 4.10-sold
'02 Z/28 vert-stock-sold and totaled
Steiner is offline  
post #7 of 8 (permalink) Old Aug 19th, 10, 10:34 PM
Senior Tech
Steps
 
Join Date: Dec 2005
Location: New Zealand
Posts: 13,321
Re: My pass side low beam keeps blowing...

As above it is a symptom of poor connections in partular bad grounds causing higher restance and too much current going thru the filiment
You would most prob also blow the hi beam if used that as much.
Check the ground from the bulb to body with a ohm meter....thats thru the spade connector, the ground poor connection could be in there and/or to the body.

My Spelling is not incorrect...it is creative

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Steptoe is offline  
post #8 of 8 (permalink) Old Aug 20th, 10, 12:30 AM Thread Starter
Gold Lifetime Member
Harley
 
wiskeesour's Avatar
 
Join Date: Nov 2006
Location: A van. Down by the river.
Posts: 6,359
Send a message via Yahoo to wiskeesour
Re: My pass side low beam keeps blowing...

OKEY DOKEY....Thanks Steps, Guys... Ill post what happens...

AE2(AW) Harley Moody, USNavy
"Master-at-Arms" for the CDWJB!!
November 26th, 2008 was my last day to serve my country as a member of the World's Greatest Navy.
Thanks Chief.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wiskeesour is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome