97 RS 3800 series II got a LOUD knock - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Dec 7th, 10, 02:31 PM Thread Starter
Josh
 
Join Date: Dec 2010
Location: Ohio
Posts: 11
97 RS 3800 series II got a LOUD knock

well, i bought this car knowing it had a possible rod knocking but the more me and my dad drive it we think that it is not a rod because a rod is more of a thud noise and this noise comes, and goes and is more of a ping and seems to come from on top of the engine. i would really appreciate any ideas as i would love to get this car fixed before summer comes around.
Thanks for your ideas!
1997CamaroRS is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Dec 7th, 10, 04:42 PM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 32,176
Garage
Re: 97 RS 3800 series II got a LOUD knock

Might have a sticky or dirty lifter. Myself to clean, I run Mobil oil and change three times every 1000 miles w/filter.
You also might add a mech oil pressure gauge just to monitor it to make sure it's not low, say below 15 PSI.

Good listening to the both of you.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden enjoy your next chapter.
Everett#2390 is online now  
post #3 of 3 (permalink) Old Dec 8th, 10, 10:01 AM Thread Starter
Josh
 
Join Date: Dec 2010
Location: Ohio
Posts: 11
Re: 97 RS 3800 series II got a LOUD knock

well here is some more information, when i started it after i got out of work last night i put it in gear, and when the rpm droped to 1k the knocking all most went away all together. and would stop for a few seconds and twice while driving the oil pressure droped off to 0 psi and then came back up in seconds...
Any ideas? i don't think the lifters would do that but im not a mechanic so please help
1997CamaroRS is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome