94 LT1 miss - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old Apr 23rd, 11, 12:56 PM Thread Starter
Donni
 
Join Date: Apr 2011
Location: Fargo, ND
Posts: 3
Question 94 LT1 miss

I just purchased a 94 LT1 Z28-6spd. The car sat all winter and as I pulled it off the trailer to drive the car, it had a fairly decent miss in the engine. As I accelerated through the gears, the miss isn't as bad but the car jerks as I accelerate. I am hoping that it is a bad batch of gas, but could it be more? Has anyone came across the same issue out there? Thanks for the replies.
3rdgenz is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old Apr 23rd, 11, 06:25 PM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,523
Garage
Re: 94 LT1 miss

A gummed up injector or broken plug wire or bad spark plug?

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - maybe this year, 2019 ...
Everett#2390 is offline  
post #3 of 6 (permalink) Old Apr 23rd, 11, 09:15 PM
Senior Tech
Ashlee and Andy
 
Join Date: Dec 2008
Location: Indiana
Posts: 178
Re: 94 LT1 miss

bad ignition module? on driver's side head. or worn out distributor/ cap may do that also. might want to just start with a tune-up. (Cap- rotor - plugs - wires and pcv)
ap68 is offline  
 
post #4 of 6 (permalink) Old Apr 24th, 11, 06:10 AM Thread Starter
Donni
 
Join Date: Apr 2011
Location: Fargo, ND
Posts: 3
Re: 94 LT1 miss

Thank you for the replies. I will start with the tune up and will let you know.
3rdgenz is offline  
post #5 of 6 (permalink) Old Apr 24th, 11, 01:10 PM
Senior Tech
darrell
 
Join Date: Feb 2011
Location: texas
Posts: 1,202
Re: 94 LT1 miss

i have a 97 with similar problems--it was injectors from setting and drom gas settiing and run thru injectors--also chek egr valve--is ther any codes if so what are the numbers on codes that will lead you to direction--make sure water pump is not leaking cause that will leak on dist. and kill it
97Z4C is offline  
post #6 of 6 (permalink) Old Apr 28th, 11, 05:25 PM Thread Starter
Donni
 
Join Date: Apr 2011
Location: Fargo, ND
Posts: 3
Re: 94 LT1 miss

I just had a diagnostic test done on the car and they told me that the distributor was shot. They quoted me $500 for the distributor and install for OEM. Can I get an aftermarket distributor that will outperform the OEM? I am a big fan of MSD but not sure if you can get MSD for the LT1. Also, if I put a high perf dist. in the car should I upgrade my plugs and wires? Any other quick mods to boost power and limit float?
3rdgenz is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome