fuel pump? - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old May 25th, 11, 03:31 PM Thread Starter
Senior Tech
Big daddy
 
Join Date: Oct 2000
Location: oklahoma city,okla.
Posts: 514
fuel pump?

Hello guys,what are the symtoms of pump failure.I havn't had a failure of on in years.Here is what I have.car will start and idle good and put in neutral a reve good.The minute let clutch go and put power to the wheels,it stutters and bucks,if I peddle it,it will catch and run good,then breakup again.Have checked timing the whole nine.What else can I do?

67ssclone 383 4spd 3.73 vintageair
carhodge is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old May 26th, 11, 02:59 AM
Senior Tech
darrell
 
Join Date: Feb 2011
Location: texas
Posts: 1,202
Re: fuel pump?

sounds like maybe carb issues-what carb u running--if qjet-sounds like power valve is stuck in down position--u can fill the vent on carb with fuel( if you put too much it will run out of ventures into motor-disconnect fuel line to carb and put fuel pressure gauge on it -start car and see what pressure you have--you can also try this without putting fuel in carb needs 5lbs of pressure--have you checked the fuel filter in carb -have this carb been setting for awhile
97Z4C is offline  
post #3 of 5 (permalink) Old May 26th, 11, 03:04 AM
Senior Tech
darrell
 
Join Date: Feb 2011
Location: texas
Posts: 1,202
Re: fuel pump?

if fuel pressure is good--filter is good and its a qjet oem carb-chek power valve in carb-u can do this by taking a small flat head screw driver a placing it in vent of carb -gently push screw driver -should feel the spring loaded power valve go up and down if not its stuck in down position and need to overhaul carb
97Z4C is offline  
 
post #4 of 5 (permalink) Old May 26th, 11, 02:42 PM
Senior Tech
Steven
 
Join Date: Jan 2001
Location: Raleigh, NC
Posts: 1,046
Re: fuel pump?

Seems like you are breaking up once car is under load ... I wander if the advance is working properly. i would revisit the distributor and make sure that everything is working properly.
sdtsdt is offline  
post #5 of 5 (permalink) Old May 26th, 11, 09:03 PM Thread Starter
Senior Tech
Big daddy
 
Join Date: Oct 2000
Location: oklahoma city,okla.
Posts: 514
Re: fuel pump?

Will try advance and carb,running 750 holley.

67ssclone 383 4spd 3.73 vintageair
carhodge is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome