emissions - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Nov 19th, 99, 08:55 AM Thread Starter
 
Join Date: Nov 1999
Posts: 1
92 rs 305 has high co and hc even though replaced filters, ox sensor, oil.
what else is there besides plugs?
Sniffman is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Nov 20th, 99, 02:40 PM
Senior Tech
 
Join Date: Nov 1998
Location: ohio
Posts: 252
Possible EGR leakage? Might pull the valve and clean. Engine heating up ok? Cold reading at temp sensor might cause this. Hummmm. tom
tom3 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome