help, my baby is hot! - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Apr 29th, 01, 09:10 AM Thread Starter
 
Join Date: Apr 2001
Location: Ennis,Tx., 75119
Posts: 5
Lightbulb

I own an '89 Camaro RS the V8 305 cu. engine has less than 7000 miles on it. 2 days ago my oil pressure dropped from 60 to 20 w/in minutes. It didn't overheat or run bad. That night the temp. skyrocketed along w/ the oil pressure being low caused my car to die. It wouldn't start for 20-30 minutes. My question is can the thermostat be stuck. If so, what are my chances of having a cracked head. A mechanic told me the overheating was lack of antifreeze & the oil was an oil sender sensor. After filling w/ antifreeze & being very careful it is still getting hot. Any suggestions??? It never got over 240 after it died the other night. My oil has been completely broken down.. The engine is still under warranty.. Help!!

[This message has been edited by tami'89 (edited 04-29-2001).]
tami'89 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Apr 29th, 01, 05:42 PM
Senior Tech
 
Join Date: Mar 2001
Location: Niceville Fl
Posts: 1,070
Post

It sounds like your oil pump might be going. I had a 90 camaro with the same motor and it did somthing like that. What is your oil pres at idal? you should have 10psi for every 1000 rpm's and a good motor will have at least 20psi at idal. If it is under warrenty I would have a mechanic check it out and then if it's bad have the warrenty fix it.
69CamaroRacer is offline  
post #3 of 3 (permalink) Old Apr 30th, 01, 01:08 PM Thread Starter
 
Join Date: Apr 2001
Location: Ennis,Tx., 75119
Posts: 5
Post

Thanks 69CamaroRacer!
The oil pressure @ idle is 0. I think the thermostat was stuck. Now, I'm being told that I have a cracked head. I'll know soon. Thanks a lot.
tami'89 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome