4speed - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Apr 2nd, 03, 06:05 PM Thread Starter
 
Join Date: Apr 2003
Posts: 16
Post

i recently bought a 69 camaro with a 4 speed not sure if it is a which muncie it is anyway i wanted to change the fluid to red line manual tranny fluid after looking tranny over could not determine how to drain old fluid only found one plug about a quater of the way up on left side of tranny ? thanks for any help
CRAZYRS is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Apr 3rd, 03, 10:21 AM
Tech Team
 
Join Date: Oct 2002
Location: Park City, UT, USA
Posts: 52
Post

If it's an original Muncie, the bottom bolt holding the two halves to the center section is drilled all the way through. Pull this bolt and the fill plug and go have a couple cool ones.
tloleson is offline  
post #3 of 5 (permalink) Old Apr 3rd, 03, 04:41 PM Thread Starter
 
Join Date: Apr 2003
Posts: 16
Post

Quote:
Originally posted by CRAZYRS:
i recently bought a 69 camaro with a 4 speed not sure if it is a which muncie it is anyway i wanted to change the fluid to red line manual tranny fluid after looking tranny over could not determine how to drain old fluid only found one plug about a quater of the way up on left side of tranny ? thanks for any help
CRAZYRS is offline  
 
post #4 of 5 (permalink) Old Apr 4th, 03, 03:08 PM
Tech Team
 
Join Date: May 2002
Location: Tacoma, WA
Posts: 97
Post

I believe only the Muncie M22 had a drain plug, the normal Muncie m-20 & M-21 drain holes were not drilled and tapped. If you want to change the oil you'll need to drill out the aluminum plug & tap it. Its on the passenger side, the alternative is to use a vacuum pump & suck out the old oil thru the fill plug u mentioned.
billyd is offline  
post #5 of 5 (permalink) Old Apr 4th, 03, 04:22 PM
Senior Tech
 
Join Date: Nov 2002
Location: Aiea, Hawaii
Posts: 571
Post

I told a guy doing my exhaust I didn't have the M22 and mine is a M20 when he said he has the same transmission. The darn thing has a drain plug on the bottom but no real loud whine. Who can tell with the loud exhaust though. I thought the M22 had some ribs on it's case?
Snatchin'gears is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome