My Speedo is acting like an *******. - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Aug 3rd, 11, 11:59 AM Thread Starter
Tech Team
Randal
 
Join Date: Mar 2011
Location: Chicago IL
Posts: 33
My Speedo is acting like an *******.

Someone know whats up with my speedo? At cruising speeds and during deceleration, and maybe even while accelerating it bounces around like the fuel gauge in a damn boat. Then when it really wants to show off it also makes a sort of buzzing / whining sound to accompany its stupid little dance. I'm not sure of the originality of the cable but it has a little sort of top-hat shaped adapter pin for the dash end. What do you guys think?
68 CoNvErTiBle is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Aug 3rd, 11, 01:37 PM
Senior Tech
Scott
 
Join Date: Jun 2006
Location: Pensacola, FL
Posts: 579
Garage
Re: My Speedo is acting like an *******.

In the past when I have experienced this problem, pulling the cable out of the jacket & oiling it has fixed it. If it gets worse, it could strip the teeth off the speedo gear. Its also possible the cable is shot. Check the cable & look for frayed areas or corrosion. If it looks good, clean & oil it. Keep us updated

69 RS LS3/T56
68 Firebird vert LS1/4L60E
67 RS LS2/T56
Z06vette is offline  
post #3 of 4 (permalink) Old Aug 3rd, 11, 01:40 PM Thread Starter
Tech Team
Randal
 
Join Date: Mar 2011
Location: Chicago IL
Posts: 33
Re: My Speedo is acting like an *******.

Thanks for the idea. The cable looks to be O.K. from the outside so I'll give it a little lube and let you know how things go.
68 CoNvErTiBle is offline  
 
post #4 of 4 (permalink) Old Aug 3rd, 11, 03:57 PM
Admin/Super Moderator
Brian
 
69-Pace's Avatar
 
Join Date: Jun 2010
Location: Connecticut USA
Posts: 12,509
Garage
Re: My Speedo is acting like an *******.

yeah use a quality gear oil so you won't be doing it again too soon.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Z11 Pace Car - L48 350cid/300hp - 4 Speed Muncie 12 bolt rear.

Super Moderator Team Camaro
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
to send me a private message
69-Pace is offline  
Sponsored Links
Advertisement
 
Reply

Tags
speedo bouncing, speedo buzzing, speedo whining

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome